summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ccac57f41a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = meson++-git
+ pkgdesc = an experimental and incomplete implementation of Meson in C++, for solving Meson's bootstrapping issue
+ pkgver = r582.3f30fd9
+ pkgrel = 1
+ url = https://github.com/dcbaker/meson-plus-plus
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ provides = meson++
+ conflicts = meson++
+ source = git+https://github.com/dcbaker/meson-plus-plus#tag=3f30fd9bfe54d7e074a273cbd680dce67cabe4eb
+ sha256sums = SKIP
+
+pkgname = meson++-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4b62e7679d6f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.install
+!/nvchecker.toml
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ef9e5827cb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# shellcheck shell=bash disable=SC2034,SC2154
+_pkgname=meson++
+pkgname=$_pkgname-git
+pkgver=r582.3f30fd9
+pkgrel=1
+pkgdesc="an experimental and incomplete implementation of Meson in C++, for solving Meson's bootstrapping issue"
+arch=(i686 x86_64 arm aarch64)
+url=https://github.com/dcbaker/meson-plus-plus
+license=(GPL3)
+makedepends=(git meson)
+conflicts=("$_pkgname")
+provides=("$_pkgname")
+source=("git+$url#tag=3f30fd9bfe54d7e074a273cbd680dce67cabe4eb")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd meson-plus-plus || return 1
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ arch-meson meson-plus-plus build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}