summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
-rw-r--r--mesquite.desktop9
-rw-r--r--mesquite.pngbin0 -> 7874 bytes
-rw-r--r--mesquite.sh4
5 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42af6958a9a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mesquite
+ pkgdesc = A software package for evolutionary biology, designed to analyze comparative data about organisms
+ pkgver = 3.04
+ pkgrel = 1
+ url = http://www.mesquiteproject.org/
+ arch = any
+ license = LGPL
+ depends = java-runtime
+ source = https://github.com/MesquiteProject/MesquiteCore/releases/download/3.04build725/Mesquite304_Linux.tar.gz
+ source = mesquite.png
+ source = mesquite.desktop
+ source = mesquite.sh
+ md5sums = 432bc66e03d68a7e7f0289510d603ce0
+ md5sums = 8b62ba93f95aab14a8643bf5b939f465
+ md5sums = ef6d47b0a7aa27329165b1185982678e
+ md5sums = 79604254490c2d8bbcbf54719ac99b6a
+
+pkgname = mesquite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5729d7f7f16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Mick Elliot <micke at sfu dot ca>
+# Maintainer: syne <madlikene at aim dot com>
+pkgname=mesquite
+pkgver=3.04
+_pkgver=304_Linux
+buildver=build725
+pkgrel=1
+pkgdesc="A software package for evolutionary biology, designed to analyze comparative data about organisms"
+arch=('any')
+url="http://www.mesquiteproject.org/"
+license=('LGPL')
+depends=('java-runtime')
+source=("https://github.com/MesquiteProject/MesquiteCore/releases/download/$pkgver$buildver/Mesquite$_pkgver.tar.gz"
+ "${pkgname}.png"
+ "${pkgname}.desktop"
+ "${pkgname}.sh")
+md5sums=('432bc66e03d68a7e7f0289510d603ce0'
+ '8b62ba93f95aab14a8643bf5b939f465'
+ 'ef6d47b0a7aa27329165b1185982678e'
+ '79604254490c2d8bbcbf54719ac99b6a')
+
+package() {
+ cd "${srcdir}/Mesquite_Folder"
+
+
+ # Install program files
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ cp -r * "${pkgdir}/usr/share/${pkgname}"
+ find "${pkgdir}/usr/share/${pkgname}" -type f -exec chmod 644 '{}' \;
+
+ # Install a launcher
+ install -Dm755 ../${pkgname}.sh "${pkgdir}/usr/bin/${pkgname}"
+
+ # Install a desktop entry
+ install -Dm644 ../${pkgname}.png "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 ../${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/mesquite.desktop b/mesquite.desktop
new file mode 100644
index 000000000000..f375a66912f2
--- /dev/null
+++ b/mesquite.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Mesquite
+Comment=A software package for evolutionary biology, designed to analyze comparative data about organisms
+Exec=mesquite
+Icon=mesquite
+Terminal=false
+Categories=Java;Education;Science;Biology;
diff --git a/mesquite.png b/mesquite.png
new file mode 100644
index 000000000000..620884c21ac9
--- /dev/null
+++ b/mesquite.png
Binary files differ
diff --git a/mesquite.sh b/mesquite.sh
new file mode 100644
index 000000000000..d12e2181fd84
--- /dev/null
+++ b/mesquite.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/mesquite
+"$JAVA_HOME/bin/java" -Djava.library.path=lib -Djri.ignore.ule="yes" -cp . mesquite.Mesquite "$@"