summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fe2cd3fafe5..52245fa91d95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,6 @@ pkgbase = meteor-rectify-git
provides = meteor-rectify
conflicts = meteor-rectify
source = meteor-rectify-git::git+https://github.com/dbdexter-dev/meteor_rectify.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = meteor-rectify-git
-
diff --git a/PKGBUILD b/PKGBUILD
index fe4011717aa0..f1831e127855 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,23 @@ pkgver=r5.fbab338
pkgrel=1
pkgdesc="Meteor-M2 image rectifier "
arch=(any)
-license=('MIT')
+license=(MIT)
url="https://github.com/dbdexter-dev/meteor_rectify"
-depends=('python' 'python-pillow' 'python-numpy')
-makedepends=('git')
-provides=('meteor-rectify')
-conflicts=('meteor-rectify')
-source=("$pkgname::git+https://github.com/dbdexter-dev/meteor_rectify.git")
-sha1sums=('SKIP')
+depends=(python python-pillow python-numpy)
+makedepends=(git)
+provides=(meteor-rectify)
+conflicts=(meteor-rectify)
+source=("${pkgname}::git+https://github.com/dbdexter-dev/meteor_rectify.git")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"
+
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd ${pkgname}
- install -Dm755 rectify.py ${pkgdir}/usr/bin/meteor-rectify
+ cd "${pkgname}"
+
+ install -Dm755 rectify.py "${pkgdir}/usr/bin/meteor_rectify"
}