summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD52
2 files changed, 36 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4445f9a983f2..18fb31229b6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = metis
- pkgdesc = A set of serial programs for partitioning graphs, partitioning finite element meshes, and producing fill reducing orderings for sparse matrices
- pkgver = 5.1.0.p11
+ pkgdesc = Serial Graph Partitioning and Fill-reducing Matrix Ordering
+ pkgver = 5.2.1
pkgrel = 1
- url = http://glaros.dtc.umn.edu/gkhome/metis/metis/overview
+ url = https://github.com/KarypisLab/METIS
arch = x86_64
- license = custom
+ license = Apache
makedepends = cmake
depends = glibc
+ depends = gklib
options = docs
- source = metis-5.1.0.p11.tar.bz2::https://bitbucket.org/petsc/pkg-metis/get/v5.1.0-p11.tar.bz2
- sha256sums = c2d5eb5a731335a2d7168eedcf2b683b990492b5ffceab1eedc2acbb7a422ff0
+ source = METIS-5.2.1.tar.gz::https://github.com/KarypisLab/METIS/archive/v5.2.1.tar.gz
+ sha512sums = 69127b7a777f9ba14cf399a7122000af9d6094a5f44be600a28384cfc0495c024fb0c6eab37c4473a5763ec1077cd9f30d9bcbb3c952462f6c9ead31c6b9e790
pkgname = metis
diff --git a/PKGBUILD b/PKGBUILD
index e827c792191f..4a6f8d891223 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,44 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: Antonio Rojas <arojas@archlinux.org>
-# Contributor: jedbrown
-# Contributor: eleftg
+# Contributor: Jed Brown <jed@jedbrown.org>
+# Contributor: George Eleftheriou <eleftg@gmail.com>
# Contributor: mickele
# Contributor: gborzi
# Contributor: abenson
-
-pkgname=metis
-pkgver=5.1.0.p11
-_pkgver=5.1.0-p11
+_base=METIS
+pkgname=${_base,,}
+pkgver=5.2.1
pkgrel=1
arch=(x86_64)
-pkgdesc="A set of serial programs for partitioning graphs, partitioning finite element meshes, and producing fill reducing orderings for sparse matrices"
-url="http://glaros.dtc.umn.edu/gkhome/metis/metis/overview"
-license=(custom)
-depends=(glibc)
+pkgdesc="Serial Graph Partitioning and Fill-reducing Matrix Ordering"
+url="https://github.com/KarypisLab/${_base}"
+license=(Apache)
+depends=(glibc gklib)
makedepends=(cmake)
options=(docs)
-source=($pkgname-$pkgver.tar.bz2::https://bitbucket.org/petsc/pkg-metis/get/v$_pkgver.tar.bz2)
-sha256sums=('c2d5eb5a731335a2d7168eedcf2b683b990492b5ffceab1eedc2acbb7a422ff0')
-
-prepare() {
- mv petsc-pkg-metis-* $pkgname-$_pkgver
-}
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('69127b7a777f9ba14cf399a7122000af9d6094a5f44be600a28384cfc0495c024fb0c6eab37c4473a5763ec1077cd9f30d9bcbb3c952462f6c9ead31c6b9e790')
build() {
- cmake -B build -S $pkgname-$_pkgver \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DSHARED=ON \
- -DMATH_LIB=m
- cmake --build build
+ cd ${_base}-${pkgver}
+ make config \
+ i64=0 \
+ r64=0 \
+ gdb=0 \
+ assert=0 \
+ assert2=0 \
+ debug=0 \
+ gprof=0 \
+ valgrind=0 \
+ openmp=0 \
+ shared=1 \
+ cc=gcc \
+ prefix=/usr \
+ gklib_path=/usr
}
package() {
- DESTDIR="$pkgdir" cmake --install build
- install -m644 -D $pkgname-$_pkgver/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd ${_base}-${pkgver}
+ make install DESTDIR="${pkgdir}"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}