summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d191f78adc8..d073d2a714fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = mgrep
+pkgbase = mgrep-trie
pkgdesc = print lines that match millions of strings efficiently
pkgver = 20190121
pkgrel = 1
@@ -7,8 +7,8 @@ pkgbase = mgrep
license = GPL
makedepends = gcc
depends = gcc-libs
- source = mgrep::git+https://github.com/daimh/mgrep.git
+ source = mgrep-trie::git+https://github.com/daimh/mgrep.git
md5sums = SKIP
-pkgname = mgrep
+pkgname = mgrep-trie
diff --git a/PKGBUILD b/PKGBUILD
index e31fe03933b7..f77f9c72f9af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Manhong Dai <daimh@umich.edu>
-pkgname=mgrep
+pkgname=mgrep-trie
pkgver=20190121
pkgrel=1
pkgdesc="print lines that match millions of strings efficiently"
@@ -24,13 +24,13 @@ build() {
cd $pkgname
./configure
make
- rm -f man/$pkgname.1.gz
- gzip man/$pkgname.1
+ rm -f man/mgrep.1.gz
+ gzip man/mgrep.1
}
check() {
- $pkgname/src/$pkgname --version
+ $pkgname/src/mgrep --version
}
package() {
- install -Dm755 $pkgname/src/$pkgname "$pkgdir/usr/bin/$pkgname"
- install -Dm644 $pkgname/man/$pkgname.1.gz "$pkgdir/usr/share/man/man1/$pkgname.1.gz"
+ install -Dm755 $pkgname/src/mgrep "$pkgdir/usr/bin/mgrep"
+ install -Dm644 $pkgname/man/mgrep.1.gz "$pkgdir/usr/share/man/man1/mgrep.1.gz"
}