summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3251622fe37..886c035a7640 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,7 +19,10 @@ pkgname = mhwd-garuda-git
depends = mesa
depends = mhwd-db-garuda-git
depends = pacman
- optdepends = lib32-mesa: for 32bit libgl support
+ depends = mesa-demos
+ depends = vulkan-tools
+ depends = libva-utils
+ depends = vdpauinfo
provides = mhwd
provides = mhwd-garuda
conflicts = mhwd
diff --git a/PKGBUILD b/PKGBUILD
index cf322c6126f8..6a085f278587 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,13 +37,11 @@ build() {
package_mhwd-garuda-git() {
pkgdesc="mhwd-garuda(manjaro's mhwd backported to archlinux with additional features and limited to only dkms drivers)"
- depends=('hwinfo' 'mesa' 'mhwd-db-garuda-git' 'pacman')
+ depends=('hwinfo' 'mesa' 'mhwd-db-garuda-git' 'pacman' 'mesa-demos' 'vulkan-tools' 'libva-utils' 'vdpauinfo')
+ depends_x86_64=("lib32-mesa" "lib32-mesa-demos")
provides=("mhwd" "mhwd-garuda")
conflicts=("mhwd" "mhwd-garuda")
replaces=("mhwd-garuda")
- if [ "${CARCH}" = "x86_64" ]; then
- optdepends=('lib32-mesa: for 32bit libgl support')
- fi
install=mhwd.install
cd ${srcdir}/mhwd-garuda