summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
-rw-r--r--micronucleus.install9
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..947c8772906f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sat Mar 26 14:56:35 UTC 2016
+pkgbase = micronucleus-git
+ pkgdesc = ATTiny usb bootloader with a strong emphasis on bootloader compactness
+ pkgver = 2.01.r13.gb23ba5b
+ pkgrel = 1
+ url = https://github.com/micronucleus/micronucleus
+ arch = any
+ license = GPL
+ provides = micronucleus
+ source = git+https://github.com/micronucleus/micronucleus
+ sha1sums = SKIP
+
+pkgname = micronucleus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60f4130c9c39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yuval Adam <yuv dot adm at gmail dot com> PGP-Key: CC2115C12D99D2F0
+
+pkgname=micronucleus-git
+pkgver=2.01.r13.gb23ba5b
+pkgrel=1
+pkgdesc="ATTiny usb bootloader with a strong emphasis on bootloader compactness"
+arch=('any')
+url="https://github.com/micronucleus/micronucleus"
+license=(GPL)
+provides=('micronucleus')
+source=("git+$url")
+sha1sums=('SKIP')
+_gitname=micronucleus
+
+pkgver() {
+ cd $_gitname
+ git describe --tags | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_gitname/commandline"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}/commandline"
+ install -Dm755 micronucleus "${pkgdir}/usr/bin/micronucleus"
+ install -Dm644 49-micronucleus.rules "${pkgdir}/etc/udev/rules.d/49-micronucleus.rules"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/micronucleus.install b/micronucleus.install
new file mode 100644
index 000000000000..a5fe2b8daf09
--- /dev/null
+++ b/micronucleus.install
@@ -0,0 +1,9 @@
+post_install () {
+ udevadm control --reload-rules
+}
+
+post_remove () {
+ post_install "$@"
+}
+
+# vim:ts=2 sw=2 et ft=sh: