summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
3 files changed, 60 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..2a4db4547596
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = micropython
+ pkgdesc = Python3 for microcontrollers, unix version.
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = http://micropython.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python
+ depends = readline
+ depends = libffi
+ source = https://github.com/micropython/micropython/archive/v1.4.2.tar.gz
+
+pkgname = micropython
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e7787deb6a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = micropython
+ pkgdesc = Python3 for microcontrollers, unix version.
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = http://micropython.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python
+ depends = readline
+ depends = libffi
+ source = https://github.com/micropython/micropython/archive/v1.4.2.tar.gz
+ md5sums = bc84f9f2ae2ef782b490a6afc3a2a666
+
+pkgname = micropython
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c27d89f67d19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+pkgname=micropython
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="Python3 for microcontrollers, unix version."
+arch=('i686' 'x86_64')
+url="http://micropython.org/"
+license=('MIT')
+depends=('readline' 'libffi')
+makedepends=('python')
+source=(https://github.com/micropython/micropython/archive/v$pkgver.tar.gz)
+md5sums=('bc84f9f2ae2ef782b490a6afc3a2a666')
+
+build() {
+ cd "$pkgname-$pkgver/unix"
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver/unix"
+ #make test
+}
+
+package() {
+ cd "$pkgname-$pkgver/unix"
+ install -Dm755 micropython "$pkgdir/usr/bin/micropython"
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+