summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2185ce1af15d..a946b4877af3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jan 16 21:44:43 UTC 2019
+# Tue Jan 29 03:07:52 UTC 2019
pkgbase = micropython
pkgdesc = Python3 for microcontrollers, with stdlib. (unix version)
- pkgver = 1.9.4
+ pkgver = 1.10
pkgrel = 1
url = http://micropython.org/
arch = i686
@@ -15,12 +15,12 @@ pkgbase = micropython
depends = libffi
depends = mbedtls
options = !emptydirs
- source = mpy-1.9.4.tgz::https://github.com/micropython/micropython/archive/v1.9.4.tar.gz
+ source = mpy-1.10.tgz::https://github.com/micropython/micropython/archive/v1.10.tar.gz
source = mlib-1.9.3.tgz::https://github.com/micropython/micropython-lib/archive/v1.9.3.tar.gz
source = axtls-1.8.2.tgz::https://github.com/pfalcon/axtls/archive/v1.8.2.tar.gz
source = ffi-3.2.1.tgz::https://github.com/libffi/libffi/archive/v3.2.1.tar.gz
source = bdb.tgz::https://github.com/pfalcon/berkeley-db-1.xx/archive/embedded.tar.gz
- md5sums = 5091802d5d9b7dd47e80ea6fc084ca6c
+ md5sums = 335d51f6f66a8f6dac95f4a53d0af579
md5sums = 1752ce13e851a671a07ce3f7a807b21c
md5sums = e11da4ef04499030d1eff69b474f34f0
md5sums = 9066486bcab807f7ddaaf2596348c1db
diff --git a/PKGBUILD b/PKGBUILD
index c6b474aaf755..5c49f06e6641 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kyle Keen <keenerd@gmail.com>
pkgbase=micropython
pkgname=(micropython micropython-lib)
-pkgver=1.9.4
+pkgver=1.10
_libver=1.9.3
# stupid submodules
_axver=1.8.2
@@ -21,7 +21,7 @@ source=("mpy-$pkgver.tgz::https://github.com/micropython/micropython/archive/v$p
"bdb.tgz::https://github.com/pfalcon/berkeley-db-1.xx/archive/embedded.tar.gz") # submodule with no releases!
# What about the lwip submodule? The repo is GONE. You didn't need an IP stack anyway.
# Maybe http://download.savannah.gnu.org/releases/lwip/lwip-2.0.0.zip is it?
-md5sums=('5091802d5d9b7dd47e80ea6fc084ca6c'
+md5sums=('335d51f6f66a8f6dac95f4a53d0af579'
'1752ce13e851a671a07ce3f7a807b21c'
'e11da4ef04499030d1eff69b474f34f0'
'9066486bcab807f7ddaaf2596348c1db'
@@ -53,7 +53,7 @@ prepare() {
build() {
cd "$srcdir/micropython-$pkgver/ports/unix"
- make libffi
+ #make libffi
#make V=1 deplibs
make
cd "$srcdir/micropython-lib-$_libver"
@@ -77,6 +77,7 @@ package_micropython-lib() {
cd "$srcdir/micropython-lib-$_libver"
for _d in $(find -mindepth 1 -maxdepth 1 -type d); do
# todo, figure out what provides this
+ # maybe importlib.metadata in python 3.8?
if grep -qr 'import metadata' ./$_d/*; then
error "Skipping $_d (bad import)"
continue