summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD52
2 files changed, 57 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51962cc02edb..0935658ba04a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Mar 17 21:50:19 UTC 2016
+# Tue Jan 24 17:57:33 UTC 2017
pkgbase = micropython
pkgdesc = Python3 for microcontrollers, with stdlib. (unix version)
- pkgver = 1.6
+ pkgver = 1.8.7
pkgrel = 1
url = http://micropython.org/
arch = i686
@@ -10,13 +10,21 @@ pkgbase = micropython
license = MIT
makedepends = python
makedepends = python-setuptools
+ makedepends = git
depends = readline
depends = libffi
+ depends = mbedtls
options = !emptydirs
- source = https://github.com/micropython/micropython/archive/v1.6.tar.gz
- source = https://github.com/micropython/micropython-lib/archive/v1.0.tar.gz
- md5sums = e5c53c2c19bb454d0854b2ed8896e43c
- md5sums = d4092764630314609ef2a4d2d9d26d14
+ source = mpy-1.8.7.tgz::https://github.com/micropython/micropython/archive/v1.8.7.tar.gz
+ source = mlib-1.8.6.tgz::https://github.com/micropython/micropython-lib/archive/v1.8.6.tar.gz
+ source = axtls-1.8.2.tgz::https://github.com/pfalcon/axtls/archive/v1.8.2.tar.gz
+ source = ffi-3.2.1.tgz::https://github.com/libffi/libffi/archive/v3.2.1.tar.gz
+ source = bdb.tgz::https://github.com/pfalcon/berkeley-db-1.xx/archive/embedded.tar.gz
+ md5sums = 80fd6b88c05ed20886acfd2fb1ea2e11
+ md5sums = e0b313e7d6378f52607844fd30d79630
+ md5sums = e11da4ef04499030d1eff69b474f34f0
+ md5sums = 9066486bcab807f7ddaaf2596348c1db
+ md5sums = 14ba0a830ddb10a309f0f1965f05cf84
pkgname = micropython
diff --git a/PKGBUILD b/PKGBUILD
index 52617620f763..d9ab1bf1b6d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,61 @@
# Maintainer: Kyle Keen <keenerd@gmail.com>
pkgbase=micropython
pkgname=(micropython micropython-lib)
-pkgver=1.6
-_libver=1.0
+pkgver=1.8.7
+_libver=1.8.6
+# stupid submodules
+_axver=1.8.2
+_ffiver=3.2.1
pkgrel=1
pkgdesc="Python3 for microcontrollers, with stdlib. (unix version)"
arch=('i686' 'x86_64')
url="http://micropython.org/"
license=('MIT')
-depends=('readline' 'libffi')
-makedepends=('python' 'python-setuptools')
+depends=('readline' 'libffi' 'mbedtls')
+makedepends=('python' 'python-setuptools' 'git')
options=('!emptydirs')
-source=("https://github.com/micropython/micropython/archive/v$pkgver.tar.gz"
- "https://github.com/micropython/micropython-lib/archive/v$_libver.tar.gz")
-md5sums=('e5c53c2c19bb454d0854b2ed8896e43c'
- 'd4092764630314609ef2a4d2d9d26d14')
+source=("mpy-$pkgver.tgz::https://github.com/micropython/micropython/archive/v$pkgver.tar.gz"
+ "mlib-$_libver.tgz::https://github.com/micropython/micropython-lib/archive/v$_libver.tar.gz"
+ "axtls-$_axver.tgz::https://github.com/pfalcon/axtls/archive/v$_axver.tar.gz" # completely broken
+ "ffi-$_ffiver.tgz::https://github.com/libffi/libffi/archive/v$_ffiver.tar.gz"
+ "bdb.tgz::https://github.com/pfalcon/berkeley-db-1.xx/archive/embedded.tar.gz") # submodule with no releases!
+# What about the lwip submodule? The repo is GONE. You didn't need an IP stack anyway.
+# Maybe http://download.savannah.gnu.org/releases/lwip/lwip-2.0.0.zip is it?
+md5sums=('80fd6b88c05ed20886acfd2fb1ea2e11'
+ 'e0b313e7d6378f52607844fd30d79630'
+ 'e11da4ef04499030d1eff69b474f34f0'
+ '9066486bcab807f7ddaaf2596348c1db'
+ '14ba0a830ddb10a309f0f1965f05cf84')
+
# todo:
# fix 'imported as namespace package' warnings from stdlib
-build() {
+prepare() {
+ cd "$srcdir/micropython-$pkgver/lib"
+ # fix submodules
+ rmdir axtls
+ rmdir libffi
+ rmdir berkeley-db-1.xx
+ ln -s "$srcdir/axtls-$_axver" axtls
+ ln -s "$srcdir/libffi-$_ffiver" libffi
+ ln -s "$srcdir/berkeley-db-1.xx-embedded" berkeley-db-1.xx
+
+ # fix makefile
cd "$srcdir/micropython-$pkgver/unix"
sed -i 's|/local||' Makefile
+ sed -i 's|git clean -d -x -f||' Makefile
+
+ # use mbedtls
+ sed -i 's/MICROPY_PY_USSL = 1/MICROPY_PY_USSL = 0/' mpconfigport.mk
+ sed -i 's/MICROPY_SSL_AXTLS = 1/MICROPY_SSL_AXTLS = 0/' mpconfigport.mk
+ sed -i 's/MICROPY_SSL_MBEDTLS = 0/MICROPY_SSL_MBEDTLS = 1/' mpconfigport.mk
+}
+
+build() {
+ cd "$srcdir/micropython-$pkgver/unix"
+ make libffi
+ #make V=1 deplibs
make
cd "$srcdir/micropython-lib-$_libver"
make