summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD29
3 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76b86a95f8c3..158ad7023373 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = midiomatic
- pkgdesc = A collection of MIDI filter, generator and processor LV2 and VST plugins
+ pkgdesc = A collection of MIDI filter, generator and processor LV2 and VST2 plugins
pkgver = 0.2.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/SpotlightKid/midiomatic
arch = x86_64
+ arch = aarch64
groups = pro-audio
groups = lv2-plugins
groups = vst-plugins
@@ -11,6 +12,8 @@ pkgbase = midiomatic
checkdepends = kxstudio-lv2-extensions
checkdepends = lv2lint
depends = gcc-libs
+ optdepends = lv2-host: for LV2 plugins
+ optdepends = vst-host: for VST plugins
source = https://github.com/SpotlightKid/midiomatic/releases/download/v0.2.1/midiomatic-0.2.1.tar.gz
sha256sums = aed203bde8fd01e279e058d48f084754f50b9fd758d7b56b845f11d8fbdbb1f3
diff --git a/.gitignore b/.gitignore
index cf2622e7d56d..57e7fd90984f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,4 @@
pkg/
src/
-midiomatic-*.tar.gz
-midiomatic-*.pkg.tar.xz
-midiomatic-*.pkg.tar.zst
-midiomatic-*.src.tar.gz
-.AURINFO
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index e8b87ca17084..fa2ea4dc91ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,39 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Maintainer: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname=midiomatic
-pkgver="0.2.1"
-pkgrel=2
-pkgdesc="A collection of MIDI filter, generator and processor LV2 and VST plugins"
-arch=(x86_64)
-url="https://github.com/SpotlightKid/midiomatic"
+pkgver=0.2.1
+pkgrel=3
+pkgdesc='A collection of MIDI filter, generator and processor LV2 and VST2 plugins'
+arch=(x86_64 aarch64)
+url='https://github.com/SpotlightKid/midiomatic'
license=(MIT)
groups=(pro-audio lv2-plugins vst-plugins)
depends=(gcc-libs)
checkdepends=(kxstudio-lv2-extensions lv2lint)
+optdepends=(
+ 'lv2-host: for LV2 plugins'
+ 'vst-host: for VST plugins'
+)
source=(
- "https://github.com/SpotlightKid/midiomatic/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+ "https://github.com/SpotlightKid/midiomatic/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
)
sha256sums=('aed203bde8fd01e279e058d48f084754f50b9fd758d7b56b845f11d8fbdbb1f3')
build() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
make -j1
}
check() {
- cd "$pkgname-$pkgver"
- make -j1 check
+ cd $pkgname-$pkgver
+ make check
}
package() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
# install plugin LV2 bundles and VST binaries
- make -j1 PREFIX=/usr DESTDIR="$pkgdir" install
+ make PREFIX=/usr DESTDIR="$pkgdir" install
# readme
install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
# license file