summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD61
-rw-r--r--midnight-rescue.desktop10
-rw-r--r--midnight-rescue.pngbin0 -> 325629 bytes
-rw-r--r--midnight-rescue.sh15
5 files changed, 48 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01d3b4c3aca4..90cf2ab2b035 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
-# Generated by mksrcinfo v8
-# Fri Feb 1 03:57:52 UTC 2019
pkgbase = midnight-rescue
- pkgdesc = A classic educational game from Abandonia, played in DosBox.
+ pkgdesc = A classic educational game from Abandonia, played in DosBox
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 3
url = https://www.myabandonware.com/game/super-solvers-midnight-rescue-1r5
arch = any
license = custom-freeware
license = Abandonware
depends = dosbox
depends = unionfs-fuse
- optdepends = abandonia-menu
- source = Midnight_Rescue.zip::https://dl.myabandonware.com/t/jAmB1g825w03TW72687692W782YyoaZQu2NdYhm2XiDsI3lRwM/Super-Solvers-Midnight-Rescue_DOS_EN.zip
+ source = Midnight_Rescue.zip::http://files.abandonia.com/download.php?game=Super+Solvers+-+Midnight+Rescue&secure=da2b471ea49d5a02e5b2a87e4f8e34e5&td=1549091612
+ source = midnight-rescue.sh
+ source = midnight-rescue.desktop
+ source = midnight-rescue.png
sha256sums = 51a095a8093f549a653a67fc810d9cb385b0f81b8d1c2e0c8cf7fca0adc363c6
+ sha256sums = 514e0d3e0443569cfcdfd6660ebd4944aa8c62bd7795f45aa280714c1205d0eb
+ sha256sums = a596dbf056cf9e28d8c6a050667717d4d37f662206f02329c42b78aea963edbf
+ sha256sums = 5ee1dc824f4012952337fe2b4fdfc5bef140a3117fb4279b3454f91400b5d484
pkgname = midnight-rescue
-
diff --git a/PKGBUILD b/PKGBUILD
index ec349094fc4f..4da4b046a1e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,25 @@
# Maintainer: twa022 <twa022 at gmail dot com>
-pkgname="midnight-rescue"
+pkgname='midnight-rescue'
pkgver=1.0
-pkgrel=1
-pkgdesc="A classic educational game from Abandonia, played in DosBox."
+pkgrel=3
+pkgdesc='A classic educational game from Abandonia, played in DosBox'
url='https://www.myabandonware.com/game/super-solvers-midnight-rescue-1r5'
arch=('any')
license=('custom-freeware' 'Abandonware')
depends=('dosbox' 'unionfs-fuse')
-optdepends=('abandonia-menu')
-source=('Midnight_Rescue.zip::https://dl.myabandonware.com/t/jAmB1g825w03TW72687692W782YyoaZQu2NdYhm2XiDsI3lRwM/Super-Solvers-Midnight-Rescue_DOS_EN.zip')
-sha256sums=('51a095a8093f549a653a67fc810d9cb385b0f81b8d1c2e0c8cf7fca0adc363c6')
-_icon="midnight_rescue.png"
+source=('Midnight_Rescue.zip::http://files.abandonia.com/download.php?game=Super+Solvers+-+Midnight+Rescue&secure=da2b471ea49d5a02e5b2a87e4f8e34e5&td=1549091612'
+ ${pkgname}.{sh,desktop,png})
+sha256sums=('51a095a8093f549a653a67fc810d9cb385b0f81b8d1c2e0c8cf7fca0adc363c6'
+ '514e0d3e0443569cfcdfd6660ebd4944aa8c62bd7795f45aa280714c1205d0eb'
+ 'a596dbf056cf9e28d8c6a050667717d4d37f662206f02329c42b78aea963edbf'
+ '5ee1dc824f4012952337fe2b4fdfc5bef140a3117fb4279b3454f91400b5d484')
package() {
+ install -dm755 "${pkgdir}"/opt/abandonia/${pkgname}
+ cp -ar SSR/* "${pkgdir}"/opt/abandonia/${pkgname}
- install -d -m755 "$pkgdir/opt/abandonia/$pkgname"
- cp -ar "$srcdir"/SSR/* "$pkgdir/opt/abandonia/$pkgname"
-
- #ok, let's use a script to start the game
-
- install -d -m755 $pkgdir/usr/bin/
- cat <<- __EOF__ > "$pkgdir/usr/bin/$pkgname"
- #!/bin/sh
- if whereis unionfs-fuse>/dev/null 2>&1; then
- if whereis dosbox>/dev/null 2>&1; then
- mkdir -p ~/.abandonia/$pkgname/temp
- mkdir -p ~/.abandonia/$pkgname/persistent
- unionfs -o cow -o umask=000 ~/.abandonia/$pkgname/persistent=RW:/opt/abandonia/$pkgname=RO ~/.abandonia/$pkgname/temp
- dosbox ~/.abandonia/$pkgname/temp/SSR.EXE
- fusermount -u ~/.abandonia/$pkgname/temp
- else
- echo '==> Please be sure to have dosbox installed and in your PATH.'
- fi
- else
- echo '==> Please be sure to have unionfs-fuse installed and in your PATH.'
- fi
- __EOF__
- chmod +x "$pkgdir/usr/bin/$pkgname"
-
- # Automatic generation of a .desktop file
-
- install -d -m755 "$pkgdir/usr/share/applications/"
-
- cat <<- __EOF__ > "$pkgdir/usr/share/applications/$pkgname.desktop"
- [Desktop Entry]
- Version=Midnight Rescue
- Type=Application
- Name=$pkgname
- Comment=$pkgdesc
- Exec=/usr/bin/$pkgname
- # Icon=/opt/abandonia/$pkgname/$_icon
- Categories=Game;Abandonia;
- Terminal=false
- StartupNotify=false
- __EOF__
+ install -Dm755 ${pkgname}.sh "${pkgdir}"/usr/bin/${pkgname}
+ install -Dm644 ${pkgname}.png -t "${pkgdir}"/usr/share/pixmaps/
+ install -Dm644 ${pkgname}.desktop -t "${pkgdir}"/usr/share/applications/
}
diff --git a/midnight-rescue.desktop b/midnight-rescue.desktop
new file mode 100644
index 000000000000..dac2bc0c3308
--- /dev/null
+++ b/midnight-rescue.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=Midnight Rescue
+Type=Application
+Name=Midnight Rescue
+Comment=A classic educational game from Abandonia, played in DosBox.
+Exec=/usr/bin/midnight-rescue
+Icon=midnight-rescue
+Categories=Game;Abandonia;
+Terminal=false
+StartupNotify=false
diff --git a/midnight-rescue.png b/midnight-rescue.png
new file mode 100644
index 000000000000..017dfc6ee0c3
--- /dev/null
+++ b/midnight-rescue.png
Binary files differ
diff --git a/midnight-rescue.sh b/midnight-rescue.sh
new file mode 100644
index 000000000000..5dcc39c45d93
--- /dev/null
+++ b/midnight-rescue.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+if whereis unionfs-fuse>/dev/null 2>&1; then
+ if whereis dosbox>/dev/null 2>&1; then
+ mkdir -p ~/.abandonia/midnight-rescue/temp
+ mkdir -p ~/.abandonia/midnight-rescue/persistent
+ unionfs -o cow -o umask=000 ~/.abandonia/midnight-rescue/persistent=RW:/opt/abandonia/midnight-rescue=RO ~/.abandonia/midnight-rescue/temp
+ dosbox ~/.abandonia/midnight-rescue/temp/SSR.EXE
+ fusermount -u ~/.abandonia/midnight-rescue/temp
+ else
+ echo '==> Error: dosbox not found'
+ fi
+else
+ echo '==> Error: unionfs-fuse not found'
+fi