summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0b9bbf7c112..c4136562bcaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
# Generated by mksrcinfo v8
-# Sat Apr 29 13:22:00 UTC 2017
+# Sun Dec 31 20:01:16 UTC 2017
pkgbase = midori-granite
pkgdesc = A lightweight, fast, and free web browser
pkgver = 0.5.11
- pkgrel = 1
+ pkgrel = 2
url = http://midori-browser.org/
install = midori.install
- arch = i686
arch = x86_64
groups = pantheon
license = LGPL2.1
@@ -29,7 +28,7 @@ pkgbase = midori-granite
depends = libxss
depends = pango
depends = sqlite
- depends = webkitgtk
+ depends = webkit2gtk
depends = zeitgeist
depends = libgranite.so
optdepends = aria2: Download utility
diff --git a/PKGBUILD b/PKGBUILD
index 307ac446b14b..b97e3101d77e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=midori-granite
pkgver=0.5.11
-pkgrel=1
+pkgrel=2
pkgdesc='A lightweight, fast, and free web browser'
arch=('x86_64')
url='http://midori-browser.org/'
@@ -10,7 +10,7 @@ license=('LGPL2.1')
groups=('pantheon')
depends=('cairo' 'desktop-file-utils' 'gcr' 'gdk-pixbuf2' 'glib2' 'glibc'
'gtk3' 'hicolor-icon-theme' 'libsoup' 'libx11' 'libxml2' 'libxss'
- 'pango' 'sqlite' 'webkitgtk' 'zeitgeist'
+ 'pango' 'sqlite' 'webkit2gtk' 'zeitgeist'
'libgranite.so')
makedepends=('cmake' 'intltool' 'librsvg' 'ninja' 'vala')
optdepends=('aria2: Download utility'
@@ -25,29 +25,36 @@ source=("http://midori-browser.org/downloads/midori_${pkgver}_all_.tar.bz2")
sha256sums=('96191a96be71144ae848a409fae5a1d6d52a00e583f33122081f47ead9c49c3d')
prepare() {
- cd midori-${pkgver}
-
if [[ -d build ]]; then
rm -rf build
fi
mkdir build
+
+ cd midori-${pkgver}
+
+ sed 's/protected Tally/public Tally/g' -i midori/midori-notebook.vala
+ sed 's/%d other files/%u other files/g' -i extensions/transfers.vala
+ for f in transfers adblock/widgets apps history-list notes; do
+ sed 's/.remove (iter/.remove (ref iter/g' -i "extensions/$f.vala"
+ done
}
build() {
- cd midori-${pkgver}/build
+ cd build
- cmake .. \
+ cmake ../midori-${pkgver} \
-DCMAKE_BUILD_TYPE='Release' \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR='/usr/lib' \
- -DUSE_GRANITE='TRUE' \
- -DUSE_GTK3='TRUE' \
+ -DHALF_BRO_INCOM_WEBKIT2='ON' \
+ -DUSE_GRANITE='ON' \
+ -DUSE_GTK3='ON' \
-G Ninja
ninja
}
package() {
- cd midori-${pkgver}/build
+ cd build
DESTDIR="${pkgdir}" ninja install
}