summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--twitter-text.patch20
3 files changed, 32 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f30edb1eb559..c4adf7fe3f12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mikutter
pkgdesc = a moest twitter client
pkgver = 3.6.4
- pkgrel = 2
+ pkgrel = 3
url = http://mikutter.hachune.net/
arch = i686
arch = x86_64
@@ -18,8 +18,10 @@ pkgbase = mikutter
optdepends = libnotify: notify support
source = http://mikutter.hachune.net/bin/mikutter.3.6.4.tar.gz
source = mikutter.desktop
+ source = twitter-text.patch
md5sums = e83f488aa9d1278f6abf27ca655f572d
md5sums = 18e28a76097af88457462b08752382df
+ md5sums = 6dc497afdbea6de76d0023e541f5d39c
pkgname = mikutter
diff --git a/PKGBUILD b/PKGBUILD
index c58f68fd10e9..a7cb60a5f476 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mikutter
pkgver=3.6.4
-pkgrel=2
+pkgrel=3
pkgdesc="a moest twitter client"
arch=('i686' 'x86_64')
url="http://mikutter.hachune.net/"
@@ -18,8 +18,14 @@ source=(
#http://mikutter.hachune.net/bin/$pkgname.$pkgver.tar.gz
http://mikutter.hachune.net/bin/$pkgname.`echo "$pkgver" | tr "_" '-'`.tar.gz
mikutter.desktop
+twitter-text.patch
)
+prepare() {
+ cd $pkgname/vendor/twitter-text
+ patch -u configuration.rb < "${srcdir}/twitter-text.patch"
+}
+
package() {
mkdir "$pkgdir/opt"
cp -r "$srcdir/$pkgname" "$pkgdir/opt"
@@ -37,4 +43,5 @@ EOF
}
md5sums=('e83f488aa9d1278f6abf27ca655f572d'
- '18e28a76097af88457462b08752382df')
+ '18e28a76097af88457462b08752382df'
+ '6dc497afdbea6de76d0023e541f5d39c')
diff --git a/twitter-text.patch b/twitter-text.patch
new file mode 100644
index 000000000000..bd35fd5cca09
--- /dev/null
+++ b/twitter-text.patch
@@ -0,0 +1,20 @@
+--- configuration_old.rb 2018-03-01 16:52:34.000000000 +0900
++++ configuration.rb 2018-03-01 16:56:17.495500046 +0900
+@@ -6,7 +6,7 @@
+ require 'json'
+
+ PARSER_VERSION_CLASSIC = "v1"
+- PARSER_VERSION_DEFAULT = "v2"
++ PARSER_VERSION_DEFAULT = "configuration"
+
+ class << self
+ attr_accessor :default_configuration
+@@ -21,7 +21,7 @@
+ )
+
+ CONFIG_V2 = File.join(
+- File.expand_path('../../../config', __FILE__), # project root
++ File.expand_path('../../../core/plugin/twitter', __FILE__), # project root
+ "#{PARSER_VERSION_DEFAULT}.json"
+ )
+