summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xminecraft7
3 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a44dd26504bc..bc3f1b8ca27b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
+# Generated by mksrcinfo v8
+# Thu Nov 30 08:46:33 UTC 2017
pkgbase = minecraft
pkgdesc = An open-world game whose gameplay revolves around breaking and placing blocks
pkgver = latest
- pkgrel = 26
+ pkgrel = 27
url = http://www.minecraft.net/
install = minecraft.install
arch = any
license = custom
- depends = java-runtime
+ depends = jre8-openjdk
depends = xorg-xrandr
depends = ttf-font
depends = libxtst
@@ -17,7 +19,7 @@ pkgbase = minecraft
source = minecraft.png
source = minecraft.install
source = LICENSE
- md5sums = b0795db46de753b74b44bed380b2cf94
+ md5sums = 45a068cb13e31824c941ceb3851630e5
md5sums = 85273e24404cc6865805f951487b8a1e
md5sums = ecb1bd9b6e6305987b6fb5832ab0b468
md5sums = dfecf76f9db4497399f4b7c171150c89
diff --git a/PKGBUILD b/PKGBUILD
index 46407b06c502..3d1e30297dfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# CVS for PKGBUILD is available at https://github.com/christopherobin/pkgbuilds/tree/master/minecraft
pkgname=minecraft
pkgver=latest
-pkgrel=26
+pkgrel=27
pkgdesc="An open-world game whose gameplay revolves around breaking and placing blocks"
arch=(any)
license=('custom')
url="http://www.minecraft.net/"
-depends=('java-runtime' 'xorg-xrandr' 'ttf-font' 'libxtst')
+depends=('jre8-openjdk' 'xorg-xrandr' 'ttf-font' 'libxtst')
noextract=('minecraft.jar')
source=(minecraft http://s3.amazonaws.com/Minecraft.Download/launcher/Minecraft.jar
minecraft.desktop minecraft.png minecraft.install LICENSE)
-md5sums=('b0795db46de753b74b44bed380b2cf94'
+md5sums=('45a068cb13e31824c941ceb3851630e5'
'85273e24404cc6865805f951487b8a1e'
'ecb1bd9b6e6305987b6fb5832ab0b468'
'dfecf76f9db4497399f4b7c171150c89'
diff --git a/minecraft b/minecraft
index 5d27e917394d..8b437347f388 100755
--- a/minecraft
+++ b/minecraft
@@ -1,5 +1,8 @@
#!/bin/sh
+# We need to force Java 8 here since both Java 7 and 9 currently causes the game to crash
+export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH
+
# Since launching the minecraft launch from the home directory bypass the update mechanism, I'm adding this
# small piece of code that will do a checksum of the versions.json file provided by mojang, if a new version
# of the game is out, I force a download of the launcher just to keep everyone up to date
@@ -9,7 +12,7 @@ MC_VERSION_URL=${MC_VERSION_URL:-"https://launchermeta.mojang.com/mc/game/versio
MC_SUM_FILE=${MC_SUM_FILE:-"${HOME}/.minecraft/versions.sum"}
# compute sums
-MC_VERSION_SUM=$( curl -s https://launchermeta.mojang.com/mc/game/version_manifest.json | sha256sum | cut -f 1 -d " " )
+MC_VERSION_SUM=$( curl -s "${MC_VERSION_URL}" | sha256sum | cut -f 1 -d " " )
MC_CURRENT_SUM=$( cat "$MC_SUM_FILE" 2>/dev/null )
if [ "$MC_VERSION_SUM" != "$MC_CURRENT_SUM" ]; then
@@ -23,4 +26,4 @@ else
exec java -jar /usr/share/minecraft/Minecraft.jar $@
fi
-unset MC_FORCE_UPDATE \ No newline at end of file
+unset MC_FORCE_UPDATE