summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD33
-rw-r--r--minecraft-pi.desktop9
-rw-r--r--minecraft-pi.install15
-rw-r--r--minecraft-pi.pngbin0 -> 102822 bytes
-rwxr-xr-xminecraft-pi.sh2
6 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..488364daaf17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 12:37:51 UTC 2016
+pkgbase = minecraft-pi
+ pkgdesc = Minecraft Pi Edition (for Raspberry Pi devices)
+ pkgver = 0.11
+ pkgrel = 1
+ url = http://pi.minecraft.net/
+ arch = armv6h
+ arch = armv7h
+ license = custom
+ makedepends = pacman>=4.2.0
+ depends = libx11
+ depends = libpng12
+ depends = desktop-file-utils
+ options = !emptydirs
+ options = !strip
+ source = minecraft-pi.sh
+ source = minecraft-pi.png
+ source = minecraft-pi.desktop
+ source = https://s3.amazonaws.com/assets.minecraft.net/pi/minecraft-pi-0.1.1.tar.gz
+ md5sums = 3da8abffae8a84c3f4abb16fd71fd406
+ md5sums = df6c93c429356fbbc633a12c03ca0089
+ md5sums = 19f3b1646fcc96db01d6ba4712e3c2e5
+ md5sums = d24f5794c0f640823f25ffcb553ce18f
+
+pkgname = minecraft-pi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..450d1e4327e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: Michele Bovo <mbovo AT gmx DOT com>
+
+pkgname=minecraft-pi
+pkgver=0.11
+pkgrel=1
+pkgdesc="Minecraft Pi Edition (for Raspberry Pi devices)"
+arch=('armv6h' 'armv7h')
+url="http://pi.minecraft.net/"
+license=('custom')
+depends=('libx11' 'libpng12' 'desktop-file-utils')
+#optdepends=('python-minecraft-pi: Python bindings for Minecraft Pi')
+makedepends=('pacman>=4.2.0')
+options=('!emptydirs' '!strip')
+#install=$pkgname.install
+source=('minecraft-pi.sh'
+'minecraft-pi.png'
+'minecraft-pi.desktop'
+'https://s3.amazonaws.com/assets.minecraft.net/pi/minecraft-pi-0.1.1.tar.gz')
+md5sums=('3da8abffae8a84c3f4abb16fd71fd406'
+'df6c93c429356fbbc633a12c03ca0089'
+'19f3b1646fcc96db01d6ba4712e3c2e5'
+'d24f5794c0f640823f25ffcb553ce18f')
+
+package() {
+ mkdir -p $pkgdir/opt/minecraft-pi
+ cp -r mcpi/* "$pkgdir/opt/minecraft-pi/"
+ install -Dm755 minecraft-pi.sh $pkgdir/usr/bin/minecraft-pi
+ install -Dm644 minecraft-pi.png $pkgdir/usr/share/pixmaps/minecraft-pi.png
+ install -Dm644 minecraft-pi.desktop $pkgdir/usr/share/applications/minecraft-pi.desktop
+ mkdir -p $pkgdir/usr/share/doc/minecraft-pi
+ mv $pkgdir/opt/minecraft-pi/*.txt $pkgdir/usr/share/doc/minecraft-pi
+}
+
diff --git a/minecraft-pi.desktop b/minecraft-pi.desktop
new file mode 100644
index 000000000000..ddab998f95ce
--- /dev/null
+++ b/minecraft-pi.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Minecraft Pi
+Comment=Fun with Blocks
+Exec=minecraft-pi
+Icon=/usr/share/pixmaps/minecraft-pi.png
+Terminal=false
+Type=Application
+Categories=Application;Game;
+StartupNotify=true
diff --git a/minecraft-pi.install b/minecraft-pi.install
new file mode 100644
index 000000000000..3bc09aeffaf2
--- /dev/null
+++ b/minecraft-pi.install
@@ -0,0 +1,15 @@
+_update() {
+ update-desktop-database -q
+}
+
+post_install() {
+ _update
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _update
+}
diff --git a/minecraft-pi.png b/minecraft-pi.png
new file mode 100644
index 000000000000..459d713beb00
--- /dev/null
+++ b/minecraft-pi.png
Binary files differ
diff --git a/minecraft-pi.sh b/minecraft-pi.sh
new file mode 100755
index 000000000000..5dfabdc7be04
--- /dev/null
+++ b/minecraft-pi.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+cd /opt/minecraft-pi && ./minecraft-pi