summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rw-r--r--minetest-mod-markers-git.install22
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b72204e7c092
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun May 29 01:30:05 UTC 2016
+pkgbase = minetest-mod-markers-git
+ pkgdesc = markers for the Minetest mod "areas" (Mod for Minetest)
+ pkgver = 22.52d1b90
+ pkgrel = 1
+ url = https://github.com/Sokomine/markers
+ install = minetest-mod-markers-git.install
+ arch = any
+ license = custom
+ makedepends = git
+ depends = minetest
+ depends = minetest-mod-areas-git
+ optdepends = minetest-usrdir_patch
+ provides = minetest-mod-markers
+ source = minetest-mod-markers::git+https://github.com/Sokomine/markers.git
+ md5sums = SKIP
+
+pkgname = minetest-mod-markers-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1c9dcba8bc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: shellkr <revoltism+AUR$gmail.com>
+
+pkgname=minetest-mod-markers-git
+_gitname=${pkgname%-git*}
+pkgver=22.52d1b90
+pkgrel=1
+pkgdesc='markers for the Minetest mod "areas" (Mod for Minetest)'
+arch=('any')
+url="https://github.com/Sokomine/markers"
+license=('custom')
+depends=('minetest' 'minetest-mod-areas-git')
+optdepends=('minetest-usrdir_patch')
+makedepends=('git')
+provides=("$_gitname")
+install=$pkgname.install
+source=("$_gitname::git+https://github.com/Sokomine/markers.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+ cp -r * "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+}
+
diff --git a/minetest-mod-markers-git.install b/minetest-mod-markers-git.install
new file mode 100644
index 000000000000..801a1209b181
--- /dev/null
+++ b/minetest-mod-markers-git.install
@@ -0,0 +1,22 @@
+
+post_install() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' Mod will be installed to /usr/share/minetest/mods which is the default'
+ echo ' directory for mods. This is disabled by default though and needs a patch.'
+ echo ' You can install "minetest-usrdir_patch" which handles this for you.'
+ echo
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' Mod will be installed to /usr/share/minetest/mods which is the default'
+ echo ' directory for mods. This is disabled by default though and needs a patch.'
+ echo ' You can install "minetest-usrdir_patch" which handles this for you.'
+ echo
+ echo
+}