summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
-rw-r--r--minetest-mod-more_monsters-git.install26
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1fd32c83c088
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jan 31 17:51:38 UTC 2016
+pkgbase = minetest-mod-more_monsters-git
+ pkgdesc = Extra mobs for Minetest.
+ pkgver = 5.9259396
+ pkgrel = 1
+ url = https://github.com/blert2112/mobs_more_monsters
+ install = minetest-mod-more_monsters-git.install
+ arch = any
+ license = custom
+ makedepends = git
+ depends = minetest
+ depends = minetest-mod-mobs_redo-git
+ provides = minetest-mod-more_monsters
+ source = minetest-mod-more_monsters::git+https://github.com/blert2112/mobs_more_monsters.git
+ md5sums = SKIP
+
+pkgname = minetest-mod-more_monsters-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e240f29a9442
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: shellkr <revoltism+AUR$gmail.com>
+
+pkgname=minetest-mod-more_monsters-git
+_gitname=${pkgname%-git*}
+pkgver=5.9259396
+pkgrel=1
+pkgdesc='Extra mobs for Minetest.'
+arch=('any')
+url="https://github.com/blert2112/mobs_more_monsters"
+license=('custom')
+depends=('minetest' 'minetest-mod-mobs_redo-git')
+makedepends=('git')
+provides=("$_gitname")
+install=$pkgname.install
+source=("$_gitname::git+https://github.com/blert2112/mobs_more_monsters.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+ cp -r * "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+}
+
diff --git a/minetest-mod-more_monsters-git.install b/minetest-mod-more_monsters-git.install
new file mode 100644
index 000000000000..d123ced05f17
--- /dev/null
+++ b/minetest-mod-more_monsters-git.install
@@ -0,0 +1,26 @@
+
+post_install() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' You have to move the mod to your $HOME/.minetest/mods if it doesnt'
+ echo ' recognize the default install dir'
+ echo
+ echo ' sudo mv /usr/share/minetest/mods/more_monsters ~/.minetest/mods'
+ echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/more_monsters'
+ echo
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' You have to move the mod to your $HOME/.minetest/mods if it doesnt'
+ echo ' recognize the default install dir'
+ echo
+ echo ' sudo mv /usr/share/minetest/mods/more_monsters ~/.minetest/mods'
+ echo ' sudo chown -R <your user>:<your group> ~/.minetest/mods/more_monsters'
+ echo
+ echo
+}