summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--minetest-mod-prehistoric_life-git.install22
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..700c2963a761
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Oct 13 00:02:50 UTC 2018
+pkgbase = minetest-mod-prehistoric_life-git
+ pkgdesc = Adds a variety of Dinosaurs. All Dinosaurs are passive as babies but carnivores become aggressive has adults if not tamed. (Mod for Minetest)
+ pkgver = 8.3b730fe
+ pkgrel = 1
+ url = https://github.com/ElCeejoYT/prehistoric_life
+ install = minetest-mod-prehistoric_life-git.install
+ arch = any
+ license = custom
+ makedepends = git
+ optdepends = minetest-usrdir_patch
+ provides = minetest-mod-prehistoric_life
+ source = minetest-mod-prehistoric_life::git+https://github.com/ElCeejoYT/prehistoric_life.git
+ md5sums = SKIP
+
+pkgname = minetest-mod-prehistoric_life-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98fcd44ca2ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: shellkr <revoltism+AUR$gmail.com>
+
+pkgname=minetest-mod-prehistoric_life-git
+_gitname=${pkgname%-git*}
+pkgver=8.3b730fe
+pkgrel=1
+pkgdesc='Adds a variety of Dinosaurs. All Dinosaurs are passive as babies but carnivores become aggressive has adults if not tamed. (Mod for Minetest)'
+arch=('any')
+url="https://github.com/ElCeejoYT/prehistoric_life"
+license=('custom')
+depends=()
+optdepends=('minetest-usrdir_patch')
+makedepends=('git')
+provides=("$_gitname")
+install=$pkgname.install
+source=("$_gitname::git+https://github.com/ElCeejoYT/prehistoric_life.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+ cp -r * "$pkgdir/usr/share/minetest/mods/${_gitname#*mod-}"
+}
+
diff --git a/minetest-mod-prehistoric_life-git.install b/minetest-mod-prehistoric_life-git.install
new file mode 100644
index 000000000000..801a1209b181
--- /dev/null
+++ b/minetest-mod-prehistoric_life-git.install
@@ -0,0 +1,22 @@
+
+post_install() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' Mod will be installed to /usr/share/minetest/mods which is the default'
+ echo ' directory for mods. This is disabled by default though and needs a patch.'
+ echo ' You can install "minetest-usrdir_patch" which handles this for you.'
+ echo
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo '############################### NOTICE ! ###################################'
+ echo
+ echo ' Mod will be installed to /usr/share/minetest/mods which is the default'
+ echo ' directory for mods. This is disabled by default though and needs a patch.'
+ echo ' You can install "minetest-usrdir_patch" which handles this for you.'
+ echo
+ echo
+}