summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48db98ef70ba..684659795a7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-armadillo
pkgdesc = C++ linear algebra library (mingw-w64)
- pkgver = 9.870.2
+ pkgver = 10.7.5
pkgrel = 1
url = http://arma.sourceforge.net/
arch = any
@@ -12,8 +12,7 @@ pkgbase = mingw-w64-armadillo
options = !strip
options = !buildflags
options = staticlibs
- source = http://downloads.sourceforge.net/sourceforge/arma/armadillo-9.870.2.tar.xz
- sha256sums = 541b5fee4c1c412d0a508791611583fcd4e8ff67c0da0536833e694e700cf756
+ source = http://downloads.sourceforge.net/sourceforge/arma/armadillo-10.7.5.tar.xz
+ sha256sums = 5d0d9fd6b34efcba6a6fceff54c0d2d13fcbe915d7af8a30c5e72cf317d2094f
pkgname = mingw-w64-armadillo
-
diff --git a/PKGBUILD b/PKGBUILD
index fb2ab8b0c159..3020c57606ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,5 @@
-
pkgname=mingw-w64-armadillo
-pkgver=9.870.2
+pkgver=10.7.5
pkgrel=1
pkgdesc="C++ linear algebra library (mingw-w64)"
arch=('any')
@@ -10,17 +9,13 @@ depends=('mingw-w64-arpack' 'mingw-w64-hdf5')
makedepends=('mingw-w64-cmake' 'mingw-w64-boost')
options=('!strip' '!buildflags' 'staticlibs')
source=("http://downloads.sourceforge.net/sourceforge/arma/armadillo-$pkgver.tar.xz")
-sha256sums=('541b5fee4c1c412d0a508791611583fcd4e8ff67c0da0536833e694e700cf756')
+sha256sums=('5d0d9fd6b34efcba6a6fceff54c0d2d13fcbe915d7af8a30c5e72cf317d2094f')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/armadillo-$pkgver"
for _arch in ${_architectures}; do
- mkdir -p build-${_arch}-static && pushd build-${_arch}-static
- ${_arch}-cmake -DBUILD_SHARED_LIBS=OFF ..
- make
- popd
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake ..
make
@@ -30,8 +25,6 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "${srcdir}/armadillo-$pkgver/build-${_arch}-static"
- make DESTDIR="${pkgdir}" install
cd "${srcdir}/armadillo-$pkgver/build-${_arch}"
make DESTDIR="${pkgdir}" install
${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a