summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdbae7188c0c..ec0e7d9c433a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Aug 19 19:48:09 UTC 2017
+# Sat Oct 14 16:00:11 UTC 2017
pkgbase = mingw-w64-bullet
pkgdesc = A 3D Collision Detection and Rigid Body Dynamics Library for games and animation (mingw-w64)
- pkgver = 2.86.1
+ pkgver = 2.87
pkgrel = 1
url = http://www.bulletphysics.com/Bullet/
arch = any
@@ -12,8 +12,8 @@ pkgbase = mingw-w64-bullet
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/bulletphysics/bullet3/archive/2.86.1.tar.gz
- sha1sums = d0a4878ccc166902f0dcb822669d1a8e4ccc8642
+ source = https://github.com/bulletphysics/bullet3/archive/2.87.tar.gz
+ sha1sums = 31c6f6c4116f4d919eaa5119f9131bedc64d3951
pkgname = mingw-w64-bullet
diff --git a/PKGBUILD b/PKGBUILD
index 5541d8e36d55..100a07636b07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Paul Bienkowski <opatutlol@aol.com>
# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
pkgname=mingw-w64-bullet
-pkgver=2.86.1
+pkgver=2.87
pkgrel=1
pkgdesc="A 3D Collision Detection and Rigid Body Dynamics Library for games and animation (mingw-w64)"
arch=('any')
@@ -13,12 +13,16 @@ depends=('mingw-w64-crt')
options=('!strip' '!buildflags' 'staticlibs')
makedepends=('mingw-w64-cmake')
source=("https://github.com/bulletphysics/bullet3/archive/${pkgver}.tar.gz")
-sha1sums=('d0a4878ccc166902f0dcb822669d1a8e4ccc8642')
+sha1sums=('31c6f6c4116f4d919eaa5119f9131bedc64d3951')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
cd ${srcdir}/bullet3-${pkgver}
+ sed -i "s|FIND_PACKAGE(PythonLibs|#|g" CMakeLists.txt
+ sed -i "s|Ws2tcpip.h|ws2tcpip.h|g" examples/ThirdPartyLibs/clsocket/src/SimpleSocket.h
+ sed -i "s|Winsock2.h|winsock2.h|g" examples/ThirdPartyLibs/clsocket/src/StatTimer.h
+ echo "target_link_libraries (BulletRobotics ws2_32 winmm)" >> Extras/BulletRobotics/CMakeLists.txt
}
build() {
@@ -43,7 +47,6 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/bullet3-${pkgver}/build-${_arch}"
make DESTDIR="${pkgdir}" install
- mv "${pkgdir}"/usr/${_arch}/lib/*.dll "$pkgdir"/usr/${_arch}/bin/
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done