summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e57b5fbf54e..dd42ed790104 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,8 @@ pkgbase = mingw-w64-chrono-date
makedepends = mingw-w64-cmake
makedepends = mingw-w64-gcc
makedepends = git
+ options = !strip
+ options = staticlibs
options = !buildflags
source = mingw-w64-chrono-date::git+https://github.com/HowardHinnant/date#commit=9a0ee2542848ab8625984fc8cdbfb9b5414c0082
source = 538-output-date-pc-for-pkg-config.patch::https://patch-diff.githubusercontent.com/raw/HowardHinnant/date/pull/538.patch
diff --git a/PKGBUILD b/PKGBUILD
index 5668bdbe17f4..a44b68b66ee6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=mingw-w64-chrono-date
pkgver=2.4.1+134+g9a0ee25
-pkgrel=1
+pkgrel=2
pkgdesc="A date and time library based on the C++11/14/17 <chrono> header"
arch=('any')
url="https://howardhinnant.github.io/date/date.html"
license=('MIT')
-options=('!buildflags')
+options=('!strip' 'staticlibs' '!buildflags')
makedepends=(
'mingw-w64-cmake'
'mingw-w64-gcc'
@@ -51,6 +51,7 @@ build() {
-DCMAKE_CROSSCOMPILING_EMULATOR=/usr/bin/${_arch}-wine \
-DCMAKE_CXX_FLAGS="-static"
make
+ ${_arch}-strip *.dll*
popd
done
}