summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD3
-rw-r--r--toolchain-mingw.cmake1
3 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 496b13002a01..8de694120e8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Aug 17 17:47:05 UTC 2017
+# Wed Feb 7 17:25:37 UTC 2018
pkgbase = mingw-w64-cmake
pkgdesc = CMake wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 18
+ pkgrel = 19
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index d407f972aed0..e0ee37971266 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-cmake
pkgver=1
-pkgrel=18
+pkgrel=19
arch=('any')
pkgdesc="CMake wrapper for MinGW (mingw-w64)"
depends=('cmake' 'mingw-w64-gcc' 'mingw-w64-pkg-config')
@@ -17,6 +17,7 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
for _arch in ${_architectures}; do
sed "s|@TRIPLE@|${_arch}|g" toolchain-mingw.cmake > toolchain-${_arch}.cmake
+ sed "s|@PROCESSOR@|${_arch::-12}|g" toolchain-mingw.cmake > toolchain-${_arch}.cmake
sed "s|@TRIPLE@|${_arch}|g" mingw-cmake.sh > ${_arch}-cmake
sed "s|@TRIPLE@|${_arch}|g" mingw-wine.sh > ${_arch}-wine
done
diff --git a/toolchain-mingw.cmake b/toolchain-mingw.cmake
index cf00b34dc9e4..6e0136a9013a 100644
--- a/toolchain-mingw.cmake
+++ b/toolchain-mingw.cmake
@@ -1,4 +1,5 @@
set (CMAKE_SYSTEM_NAME Windows)
+set (CMAKE_SYSTEM_PROCESSOR @PROCESSOR@)
# specify the cross compiler
set (CMAKE_C_COMPILER @TRIPLE@-gcc)