summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fb12862e71d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Jul 12 00:54:19 UTC 2016
+pkgbase = mingw-w64-cppunit
+ pkgdesc = A C++ unit testing framework (mingw-w64)
+ pkgver = 1.13.2
+ pkgrel = 1
+ url = http://www.freedesktop.org/wiki/Software/cppunit
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = !libtool
+ options = staticlibs
+ options = !emptydirs
+ source = http://dev-www.libreoffice.org/src/cppunit-1.13.2.tar.gz
+ md5sums = d1c6bdd5a76c66d2c38331e2d287bc01
+
+pkgname = mingw-w64-cppunit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3f2c0674825
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Jeff 'codemac' Mickey <jeff@archlinux.org>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_name=cppunit
+pkgname=mingw-w64-cppunit
+pkgver=1.13.2
+pkgrel=1
+pkgdesc="A C++ unit testing framework (mingw-w64)"
+arch=('any')
+url="http://www.freedesktop.org/wiki/Software/cppunit"
+license=('LGPL')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-gcc' 'mingw-w64-configure')
+options=(!strip !buildflags !libtool staticlibs !emptydirs)
+source=("http://dev-www.libreoffice.org/src/${_name}-${pkgver}.tar.gz")
+md5sums=('d1c6bdd5a76c66d2c38331e2d287bc01')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}/${_name}-${pkgver}/build-${_arch}"
+ cd "${srcdir}/${_name}-${pkgver}/build-${_arch}"
+ ${_arch}-configure
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}/${_name}-${pkgver}/build-${_arch}"
+ cd "${srcdir}/${_name}-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/${_arch}/share/"
+ ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ done
+}