summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
-rw-r--r--e4c8c735d59f813acc69194030401f67883fb427.patch25
4 files changed, 36 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c553ad4d1c5..3ff1e634a059 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Dec 17 18:11:58 UTC 2016
+# Thu Dec 29 23:27:05 UTC 2016
pkgbase = mingw-w64-extra-cmake-modules
pkgdesc = Extra modules and scripts for CMake (mingw-w64)
pkgver = 5.29.0
- pkgrel = 1
+ pkgrel = 2
url = https://projects.kde.org/projects/kdesupport/extra-cmake-modules
arch = any
groups = mingw-w64-kf5
@@ -14,8 +14,10 @@ pkgbase = mingw-w64-extra-cmake-modules
options = !buildflags
source = http://download.kde.org/stable/frameworks/5.29/extra-cmake-modules-5.29.0.tar.xz
source = set-AUTOSTATICPLUGINS.patch
+ source = e4c8c735d59f813acc69194030401f67883fb427.patch
md5sums = dd3e13ee27fb421a9d215fc708ae02b3
md5sums = 0d249754247382f3b8dda80d6833aac4
+ md5sums = e977bbee6a68a1e27c7f9a766fc0a6ca
pkgname = mingw-w64-extra-cmake-modules
diff --git a/.gitignore b/.gitignore
index 436a59477780..d36132dce21e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
pkg/
src/
+*.log
*.tar
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index 5b48cc8af58b..29a8c4301d2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-extra-cmake-modules
pkgver=5.29.0
-pkgrel=1
+pkgrel=2
arch=(any)
pkgdesc="Extra modules and scripts for CMake (mingw-w64)"
groups=(mingw-w64-kf5)
@@ -9,15 +9,18 @@ depends=(mingw-w64-cmake)
options=(staticlibs !strip !buildflags)
url="https://projects.kde.org/projects/kdesupport/extra-cmake-modules"
source=("http://download.kde.org/stable/frameworks/${pkgver%.*}/extra-cmake-modules-${pkgver}.tar.xz"
-"set-AUTOSTATICPLUGINS.patch")
+"set-AUTOSTATICPLUGINS.patch"
+"e4c8c735d59f813acc69194030401f67883fb427.patch")
md5sums=('dd3e13ee27fb421a9d215fc708ae02b3'
- '0d249754247382f3b8dda80d6833aac4')
+ '0d249754247382f3b8dda80d6833aac4'
+ 'e977bbee6a68a1e27c7f9a766fc0a6ca')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd extra-cmake-modules-$pkgver
patch -p1 -i "${srcdir}"/set-AUTOSTATICPLUGINS.patch
+ patch -p1 -i "$srcdir"/e4c8c735d59f813acc69194030401f67883fb427.patch
}
build() {
diff --git a/e4c8c735d59f813acc69194030401f67883fb427.patch b/e4c8c735d59f813acc69194030401f67883fb427.patch
new file mode 100644
index 000000000000..5192f79ff783
--- /dev/null
+++ b/e4c8c735d59f813acc69194030401f67883fb427.patch
@@ -0,0 +1,25 @@
+From e4c8c735d59f813acc69194030401f67883fb427 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Thu, 29 Dec 2016 13:31:31 +0100
+Subject: [PATCH] Fix use of Qt::lconvert
+
+This workaround seems to be required
+for mingw-w64 packages, not sure what's
+the actual problem, though
+---
+ modules/ECMPoQmTools.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/modules/ECMPoQmTools.cmake b/modules/ECMPoQmTools.cmake
+index 5bc3b07..f9cc63f 100644
+--- a/modules/ECMPoQmTools.cmake
++++ b/modules/ECMPoQmTools.cmake
+@@ -144,7 +144,7 @@ function(ecm_process_po_files_as_qm lang)
+ find_package(Qt5LinguistTools CONFIG REQUIRED)
+
+ if(TARGET Qt5::lconvert)
+- set(lconvert_executable Qt5::lconvert)
++ get_target_property(lconvert_executable Qt5::lconvert IMPORTED_LOCATION)
+ else()
+ # Qt < 5.3.1 does not define Qt5::lconvert
+ get_target_property(lrelease_location Qt5::lrelease LOCATION)