summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe11b06c2298..61db2bf4bd86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-extra-cmake-modules
pkgdesc = Extra modules and scripts for CMake (mingw-w64)
- pkgver = 5.49.0
+ pkgver = 5.59.0
pkgrel = 1
url = https://community.kde.org/Frameworks
arch = any
@@ -10,12 +10,12 @@ pkgbase = mingw-w64-extra-cmake-modules
options = staticlibs
options = !strip
options = !buildflags
- source = http://download.kde.org/stable/frameworks/5.49/extra-cmake-modules-5.49.0.tar.xz
- source = http://download.kde.org/stable/frameworks/5.49/extra-cmake-modules-5.49.0.tar.xz.sig
+ source = http://download.kde.org/stable/frameworks/5.59/extra-cmake-modules-5.59.0.tar.xz
+ source = http://download.kde.org/stable/frameworks/5.59/extra-cmake-modules-5.59.0.tar.xz.sig
source = set-AUTOSTATICPLUGINS.patch
source = 05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch
validpgpkeys = 53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB
- sha256sums = c09fb851751f2e1c1231130dbce62d5dab396444fce7ed18662ada9ebd7ced1e
+ sha256sums = 1a630b242242ac32d20d14e7ae5645aa28a47676eae0e62ed76af8bc1f56c438
sha256sums = SKIP
sha256sums = 30bdcedab402c69ea0db3460f5a23cbd226a5cd1e12b13926b8a65df773e14a0
sha256sums = 7e44cf56a8274c8166eaf02e60c2d34e5048992a7e3c8309b998b762a394e909
diff --git a/PKGBUILD b/PKGBUILD
index bfab5c7e00e2..fdad7e7ebc3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-extra-cmake-modules
-pkgver=5.49.0
+pkgver=5.59.0
pkgrel=1
arch=(any)
pkgdesc="Extra modules and scripts for CMake (mingw-w64)"
@@ -11,7 +11,7 @@ url="https://community.kde.org/Frameworks"
source=("http://download.kde.org/stable/frameworks/${pkgver%.*}/extra-cmake-modules-${pkgver}.tar.xz"{,.sig}
"set-AUTOSTATICPLUGINS.patch"
"05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch")
-sha256sums=('c09fb851751f2e1c1231130dbce62d5dab396444fce7ed18662ada9ebd7ced1e'
+sha256sums=('1a630b242242ac32d20d14e7ae5645aa28a47676eae0e62ed76af8bc1f56c438'
'SKIP'
'30bdcedab402c69ea0db3460f5a23cbd226a5cd1e12b13926b8a65df773e14a0'
'7e44cf56a8274c8166eaf02e60c2d34e5048992a7e3c8309b998b762a394e909')
@@ -20,15 +20,16 @@ validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd extra-cmake-modules-$pkgver
- sed -e 's|/usr/bin/env python|/usr/bin/env python2|' -i find-modules/*.py
- patch -p1 -i "${srcdir}"/set-AUTOSTATICPLUGINS.patch
- patch -p1 -i "$srcdir"/05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch
+ cd extra-cmake-modules-$pkgver
+
+ sed -e 's|/usr/bin/env python|/usr/bin/env python2|' -i find-modules/*.py
+ patch -p1 -i "${srcdir}"/set-AUTOSTATICPLUGINS.patch
+ patch -p1 -i "$srcdir"/05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch
}
build() {
- cd extra-cmake-modules-$pkgver
- for _arch in ${_architectures}; do
+ cd extra-cmake-modules-$pkgver
+ for _arch in ${_architectures}; do
unset LDFLAGS
mkdir "build-${_arch}" && pushd "build-${_arch}"
${_arch}-cmake \
@@ -40,7 +41,7 @@ build() {
}
package() {
- for _arch in ${_architectures}; do
+ for _arch in ${_architectures}; do
cd "${srcdir}/${pkgname#mingw-w64-}-$pkgver/build-${_arch}"
make DESTDIR="$pkgdir" install
done