summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--windres.patch13
3 files changed, 28 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e11210f58ee4..5f9fb909866b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-ffmpeg-minimal
pkgdesc = Complete solution to record, convert and stream audio and video (mingw-w64)
- pkgver = 4.3.1
+ pkgver = 4.4
pkgrel = 1
epoch = 1
url = http://ffmpeg.org/
@@ -18,8 +18,9 @@ pkgbase = mingw-w64-ffmpeg-minimal
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://git.ffmpeg.org/ffmpeg.git#tag=n4.3.1
+ source = git+https://git.ffmpeg.org/ffmpeg.git#tag=n4.4
+ source = windres.patch
sha256sums = SKIP
+ sha256sums = c78ae2245fd1863ea495c115b24214d5692b86ff51b8899a23bc43a48c3385c0
pkgname = mingw-w64-ffmpeg-minimal
-
diff --git a/PKGBUILD b/PKGBUILD
index 57077fb53c45..5369f3a629f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-ffmpeg-minimal
-pkgver=4.3.1
+pkgver=4.4
pkgrel=1
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (mingw-w64)"
@@ -16,10 +16,18 @@ options=(!strip !buildflags staticlibs)
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'git' 'yasm')
provides=('mingw-w64-ffmpeg')
conflicts=('mingw-w64-ffmpeg')
-source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}")
-sha256sums=('SKIP')
+source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}"
+ "windres.patch")
+sha256sums=('SKIP'
+ 'c78ae2245fd1863ea495c115b24214d5692b86ff51b8899a23bc43a48c3385c0')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd ffmpeg
+
+ patch -Np1 -i "${srcdir}/windres.patch"
+}
+
build() {
for _arch in ${_architectures}; do
mkdir -p "${srcdir}"/build-${_arch} && cd "${srcdir}"/build-${_arch}
diff --git a/windres.patch b/windres.patch
new file mode 100644
index 000000000000..0e040f031001
--- /dev/null
+++ b/windres.patch
@@ -0,0 +1,13 @@
+diff --git a/ffbuild/common.mak b/ffbuild/common.mak
+index e070b6b5e2..ab536e157d 100644
+--- a/ffbuild/common.mak
++++ b/ffbuild/common.mak
+@@ -90,7 +90,7 @@ COMPILE_MSA = $(call COMPILE,CC,MSAFLAGS)
+ -$(if $(ASMSTRIPFLAGS), $(STRIP) $(ASMSTRIPFLAGS) $@)
+
+ %.o: %.rc
+- $(WINDRES) $(IFLAGS) --preprocessor "$(DEPWINDRES) -E -xc-header -DRC_INVOKED $(CC_DEPFLAGS)" -o $@ $<
++ $(WINDRES) $(IFLAGS) -o $@ $<
+
+ %.i: %.c
+ $(CC) $(CCFLAGS) $(CC_E) $<