summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0003-Enable-subpixel-hinting.patch25
-rw-r--r--0003-Make-subpixel-hinting-mode-configurable.patch88
-rw-r--r--0004-Keep-default-interpreter-version-as-35.patch29
-rw-r--r--0004-Mask-subpixel-hinting-with-an-env-var.patch31
-rw-r--r--PKGBUILD8
6 files changed, 9 insertions, 182 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3a445602c03..b4e46e3b9a89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Sep 24 21:48:31 UTC 2016
+# Fri Jan 6 21:34:21 UTC 2017
pkgbase = mingw-w64-freetype2
pkgdesc = TrueType font rendering library (mingw-w64)
- pkgver = 2.7
+ pkgver = 2.7.1
pkgrel = 1
url = http://www.freetype.org/
arch = any
@@ -23,12 +23,12 @@ pkgbase = mingw-w64-freetype2
options = !buildflags
options = !libtool
options = staticlibs
- source = http://download.savannah.gnu.org/releases/freetype/freetype-2.7.tar.bz2
- source = http://download.savannah.gnu.org/releases/freetype/freetype-2.7.tar.bz2.sig
+ source = http://download.savannah.gnu.org/releases/freetype/freetype-2.7.1.tar.bz2
+ source = http://download.savannah.gnu.org/releases/freetype/freetype-2.7.1.tar.bz2.sig
source = 0001-Enable-table-validation-modules.patch
source = 0002-Enable-subpixel-rendering.patch
source = 0003-Enable-infinality-subpixel-hinting.patch
- sha1sums = f251029d5ab542a96dd4531605fe577185077560
+ sha1sums = 4d08a9a6567c6332d58e9a5f9a7e9e3fbce66789
sha1sums = SKIP
sha1sums = b31882ef5e8447e761acee1c4a44c0630cd4d465
sha1sums = b1494810ed3aca25cdd8e8cedf634e5adfe6c09e
diff --git a/0003-Enable-subpixel-hinting.patch b/0003-Enable-subpixel-hinting.patch
deleted file mode 100644
index 00a5c2f79f3b..000000000000
--- a/0003-Enable-subpixel-hinting.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From f96a1d21d787b173d6293330fbf782b977194aa7 Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Tue, 23 Jun 2015 08:43:57 +0200
-Subject: [PATCH 3/4] Enable subpixel hinting
-
----
- include/freetype/config/ftoption.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
-index ab407e3..a2eab6a 100644
---- a/include/freetype/config/ftoption.h
-+++ b/include/freetype/config/ftoption.h
-@@ -602,7 +602,7 @@ FT_BEGIN_HEADER
- /* This option requires TT_CONFIG_OPTION_BYTECODE_INTERPRETER to be */
- /* defined. */
- /* */
--/* #define TT_CONFIG_OPTION_SUBPIXEL_HINTING */
-+#define TT_CONFIG_OPTION_SUBPIXEL_HINTING
-
-
- /*************************************************************************/
---
-2.6.0
-
diff --git a/0003-Make-subpixel-hinting-mode-configurable.patch b/0003-Make-subpixel-hinting-mode-configurable.patch
deleted file mode 100644
index c1441dbef1d3..000000000000
--- a/0003-Make-subpixel-hinting-mode-configurable.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From be997becc28dfbf2077cca55dc9a6a090d13e22a Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Wed, 15 Jun 2016 14:10:20 +0200
-Subject: [PATCH 3/4] Make subpixel hinting mode configurable
-
----
- include/freetype/config/ftoption.h | 2 +-
- src/truetype/ttobjs.c | 37 +++++++++++++++++++++++++++++++++++++
- 2 files changed, 38 insertions(+), 1 deletion(-)
-
-diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
-index 8e58403529f597e5..197e15cdc3cc1e74 100644
---- a/include/freetype/config/ftoption.h
-+++ b/include/freetype/config/ftoption.h
-@@ -632,7 +632,7 @@ FT_BEGIN_HEADER
- /* */
- /* #define TT_CONFIG_OPTION_SUBPIXEL_HINTING 1 */
- /* #define TT_CONFIG_OPTION_SUBPIXEL_HINTING 2 */
--/* #define TT_CONFIG_OPTION_SUBPIXEL_HINTING ( 1 | 2 ) */
-+#define TT_CONFIG_OPTION_SUBPIXEL_HINTING ( 1 | 2 )
-
-
- /*************************************************************************/
-diff --git a/src/truetype/ttobjs.c b/src/truetype/ttobjs.c
-index ed3be2dbee79427c..d89f92e94d0e816b 100644
---- a/src/truetype/ttobjs.c
-+++ b/src/truetype/ttobjs.c
-@@ -36,6 +36,9 @@
- #include "ttgxvar.h"
- #endif
-
-+#include <stdlib.h>
-+#include <errno.h>
-+
- /*************************************************************************/
- /* */
- /* The macro FT_COMPONENT is used in trace mode. It is an implicit */
-@@ -1286,6 +1289,7 @@
- #ifdef TT_USE_BYTECODE_INTERPRETER
-
- TT_Driver driver = (TT_Driver)ttdriver;
-+ const char *envval;
-
- driver->interpreter_version = TT_INTERPRETER_VERSION_35;
- #ifdef TT_SUPPORT_SUBPIXEL_HINTING_INFINALITY
-@@ -1295,6 +1299,39 @@
- driver->interpreter_version = TT_INTERPRETER_VERSION_40;
- #endif
-
-+ errno = 0;
-+ envval = getenv( "FT2_SUBPIXEL_HINTING" );
-+ if ( envval )
-+ {
-+ char *endptr = NULL;
-+ unsigned long value = strtoul( envval, &endptr, 10 );
-+
-+ if ( !errno && endptr && !*endptr )
-+ {
-+ switch( value )
-+ {
-+ case 0:
-+ driver->interpreter_version = TT_INTERPRETER_VERSION_35;
-+ break;
-+
-+#ifdef TT_SUPPORT_SUBPIXEL_HINTING_INFINALITY
-+ case 1:
-+ driver->interpreter_version = TT_INTERPRETER_VERSION_38;
-+ break;
-+#endif
-+
-+#ifdef TT_SUPPORT_SUBPIXEL_HINTING_MINIMAL
-+ case 2:
-+ driver->interpreter_version = TT_INTERPRETER_VERSION_40;
-+ break;
-+#endif
-+
-+ default:
-+ break;
-+ }
-+ }
-+ }
-+
- #else /* !TT_USE_BYTECODE_INTERPRETER */
-
- FT_UNUSED( ttdriver );
---
-2.9.0
-
diff --git a/0004-Keep-default-interpreter-version-as-35.patch b/0004-Keep-default-interpreter-version-as-35.patch
deleted file mode 100644
index ba188537f11e..000000000000
--- a/0004-Keep-default-interpreter-version-as-35.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 88e7474320b8d2b5333e276b8b1771bc2690c43f Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Tue, 12 Jul 2016 12:47:57 +0200
-Subject: [PATCH 4/4] Keep default interpreter version as 35
-
----
- src/truetype/ttobjs.c | 6 ------
- 1 file changed, 6 deletions(-)
-
-diff --git a/src/truetype/ttobjs.c b/src/truetype/ttobjs.c
-index d89f92e94d0e816b..efca66fc21c0287a 100644
---- a/src/truetype/ttobjs.c
-+++ b/src/truetype/ttobjs.c
-@@ -1292,12 +1292,6 @@
- const char *envval;
-
- driver->interpreter_version = TT_INTERPRETER_VERSION_35;
--#ifdef TT_SUPPORT_SUBPIXEL_HINTING_INFINALITY
-- driver->interpreter_version = TT_INTERPRETER_VERSION_38;
--#endif
--#ifdef TT_SUPPORT_SUBPIXEL_HINTING_MINIMAL
-- driver->interpreter_version = TT_INTERPRETER_VERSION_40;
--#endif
-
- errno = 0;
- envval = getenv( "FT2_SUBPIXEL_HINTING" );
---
-2.9.0
-
diff --git a/0004-Mask-subpixel-hinting-with-an-env-var.patch b/0004-Mask-subpixel-hinting-with-an-env-var.patch
deleted file mode 100644
index ec8910488cb3..000000000000
--- a/0004-Mask-subpixel-hinting-with-an-env-var.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From bb5ece9c6773145c8342107bd32fcacbc4b212ab Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Tue, 23 Jun 2015 08:34:54 +0200
-Subject: [PATCH 4/4] Mask subpixel hinting with an env var
-
----
- src/truetype/ttobjs.c | 7 ++++---
- 1 file changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/src/truetype/ttobjs.c b/src/truetype/ttobjs.c
-index 6060d6f..3fa98e7 100644
---- a/src/truetype/ttobjs.c
-+++ b/src/truetype/ttobjs.c
-@@ -1302,10 +1302,11 @@
- TT_Driver driver = (TT_Driver)ttdriver;
-
- #ifdef TT_CONFIG_OPTION_SUBPIXEL_HINTING
-- driver->interpreter_version = TT_INTERPRETER_VERSION_38;
--#else
-- driver->interpreter_version = TT_INTERPRETER_VERSION_35;
-+ if ( getenv( "FT2_SUBPIXEL_HINTING" ) )
-+ driver->interpreter_version = TT_INTERPRETER_VERSION_38;
-+ else
- #endif
-+ driver->interpreter_version = TT_INTERPRETER_VERSION_35;
-
- #else /* !TT_USE_BYTECODE_INTERPRETER */
-
---
-2.6.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 08e6984c3278..1cedbe341f93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-freetype2
-pkgver=2.7
+pkgver=2.7.1
pkgrel=1
pkgdesc="TrueType font rendering library (mingw-w64)"
arch=('any')
@@ -20,14 +20,14 @@ source=(http://download.savannah.gnu.org/releases/freetype/freetype-${pkgver}.ta
0002-Enable-subpixel-rendering.patch
0003-Enable-infinality-subpixel-hinting.patch)
options=(!strip !buildflags !libtool staticlibs)
-sha1sums=('f251029d5ab542a96dd4531605fe577185077560'
+sha1sums=('4d08a9a6567c6332d58e9a5f9a7e9e3fbce66789'
'SKIP'
'b31882ef5e8447e761acee1c4a44c0630cd4d465'
'b1494810ed3aca25cdd8e8cedf634e5adfe6c09e'
'41d27140fd590945e22e012c9dce62de3d6f11e6')
validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
-if [[ $pkgname = "mingw-w64-freetype2-bootstrap" ]]; then
+if [[ $pkgname = 'mingw-w64-freetype2-bootstrap' ]]; then
_provides=${pkgname%-bootstrap}
else
_provides=${pkgname}-bootstrap
@@ -39,7 +39,7 @@ fi
provides+=(${_provides})
conflicts+=(${_provides})
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
prepare() {
cd "${srcdir}/freetype-${pkgver}"