summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD50
2 files changed, 31 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a8fb5eba5f3..c577575f6107 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Dec 23 23:49:37 UTC 2015
+# Thu Feb 11 15:12:53 UTC 2016
pkgbase = mingw-w64-freetype2
pkgdesc = TrueType font rendering library (mingw-w64)
- pkgver = 2.6.2
- pkgrel = 2
+ pkgver = 2.6.3
+ pkgrel = 1
url = http://www.freetype.org/
arch = any
license = GPL
@@ -23,13 +23,13 @@ pkgbase = mingw-w64-freetype2
options = !buildflags
options = !libtool
options = staticlibs
- source = http://download.savannah.gnu.org/releases/freetype/freetype-2.6.2.tar.bz2
- source = http://download.savannah.gnu.org/releases/freetype/freetype-2.6.2.tar.bz2.sig
+ source = http://download.savannah.gnu.org/releases/freetype/freetype-2.6.3.tar.bz2
+ source = http://download.savannah.gnu.org/releases/freetype/freetype-2.6.3.tar.bz2.sig
source = 0001-Enable-table-validation-modules.patch
source = 0002-Enable-subpixel-rendering.patch
source = 0003-Enable-subpixel-hinting.patch
source = 0004-Mask-subpixel-hinting-with-an-env-var.patch
- sha1sums = 29c22b85b77cb22cf95c13e7062e21f39fe6b17a
+ sha1sums = 6c98bd5d0be313207c37ca23d25faf983486aee5
sha1sums = SKIP
sha1sums = 1c7bc438df0428a63f881e7e4343b22c5b09ecb1
sha1sums = e2d2b8c4847ab9cfd497179c7140835e99ece711
diff --git a/PKGBUILD b/PKGBUILD
index 323004a730d2..595025138cf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martchus <martchus@gmx.net>
pkgname=mingw-w64-freetype2
-pkgver=2.6.2
-pkgrel=2
+pkgver=2.6.3
+pkgrel=1
pkgdesc="TrueType font rendering library (mingw-w64)"
arch=('any')
url="http://www.freetype.org/"
@@ -19,7 +19,7 @@ source=(http://download.savannah.gnu.org/releases/freetype/freetype-${pkgver}.ta
0003-Enable-subpixel-hinting.patch
0004-Mask-subpixel-hinting-with-an-env-var.patch)
options=(!strip !buildflags !libtool staticlibs)
-sha1sums=('29c22b85b77cb22cf95c13e7062e21f39fe6b17a'
+sha1sums=('6c98bd5d0be313207c37ca23d25faf983486aee5'
'SKIP'
'1c7bc438df0428a63f881e7e4343b22c5b09ecb1'
'e2d2b8c4847ab9cfd497179c7140835e99ece711'
@@ -30,33 +30,33 @@ validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "${srcdir}/freetype-${pkgver}"
- patch -Np1 -i "${srcdir}/0001-Enable-table-validation-modules.patch"
- patch -Np1 -i "${srcdir}/0002-Enable-subpixel-rendering.patch"
+ cd "${srcdir}/freetype-${pkgver}"
+ patch -Np1 -i "${srcdir}/0001-Enable-table-validation-modules.patch"
+ patch -Np1 -i "${srcdir}/0002-Enable-subpixel-rendering.patch"
- # https://bugs.archlinux.org/task/35274
- patch -Np1 -i "${srcdir}/0003-Enable-subpixel-hinting.patch"
- # Provide a way to enable the above patch at runtime.
- # Hopefully just a temporary measure until fontconfig picks up
- # the necessary configurables.
- patch -Np1 -i "${srcdir}/0004-Mask-subpixel-hinting-with-an-env-var.patch"
+ # https://bugs.archlinux.org/task/35274
+ patch -Np1 -i "${srcdir}/0003-Enable-subpixel-hinting.patch"
+ # Provide a way to enable the above patch at runtime.
+ # Hopefully just a temporary measure until fontconfig picks up
+ # the necessary configurables.
+ patch -Np1 -i "${srcdir}/0004-Mask-subpixel-hinting-with-an-env-var.patch"
}
build() {
- for _arch in ${_architectures}; do
- mkdir -p "${srcdir}/freetype-${pkgver}/build-${_arch}"
- cd "${srcdir}/freetype-${pkgver}/build-${_arch}"
- ${_arch}-configure --with-zlib=/usr/${_arch} --without-png
- make
- done
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}/freetype-${pkgver}/build-${_arch}"
+ cd "${srcdir}/freetype-${pkgver}/build-${_arch}"
+ ${_arch}-configure --with-zlib=/usr/${_arch} --without-png
+ make
+ done
}
package() {
- for _arch in ${_architectures}; do
- cd "${srcdir}/freetype-${pkgver}/build-${_arch}"
- make DESTDIR="${pkgdir}" install
- rm -rf "${pkgdir}/usr/${_arch}/share/"
- ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- done
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/freetype-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/${_arch}/share/"
+ ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ done
}