summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--01-relocate.patch39
-rw-r--r--PKGBUILD14
3 files changed, 17 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b49bc096e7b5..a50b5607fa9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-hunspell
pkgdesc = Spell checker and morphological analyzer library and program (mingw-w64)
- pkgver = 1.6.2
+ pkgver = 1.7.0
pkgrel = 1
url = https://hunspell.github.io/
arch = any
@@ -18,10 +18,10 @@ pkgbase = mingw-w64-hunspell
options = staticlibs
options = !debug
options = !emptydirs
- source = hunspell-1.6.2.tar.gz::https://github.com/hunspell/hunspell/archive/v1.6.2.tar.gz
+ source = hunspell-1.7.0.tar.gz::https://github.com/hunspell/hunspell/archive/v1.7.0.tar.gz
source = 01-relocate.patch
- sha256sums = 3cd9ceb062fe5814f668e4f22b2fa6e3ba0b339b921739541ce180cac4d6f4c4
- sha256sums = 2730c6cbca341db54f5d4a53a81c89f8e91ac6e3060af9740f5bb15185067806
+ sha256sums = bb27b86eb910a8285407cf3ca33b62643a02798cf2eef468c0a74f6c3ee6bc8a
+ sha256sums = b3a978749ef723481286e6237944729b6965bc57eacc5407b5f7fedf7d6aa8a1
pkgname = mingw-w64-hunspell
diff --git a/01-relocate.patch b/01-relocate.patch
index 66587a96f4b7..86e722a84d75 100644
--- a/01-relocate.patch
+++ b/01-relocate.patch
@@ -1,41 +1,27 @@
-diff --git a/.gitignore b/.gitignore
-index 04cdd34..5ede546 100644
---- a/.gitignore
-+++ b/.gitignore
-@@ -51,7 +51,8 @@ Makefile
- /config.status
- /hunspell.pc
- /libtool
--
-+build/*
-+.vscode/*
-
- #make
- .deps/
diff --git a/src/tools/Makefile.am b/src/tools/Makefile.am
index 4c29f1a..cc25476 100644
--- a/src/tools/Makefile.am
+++ b/src/tools/Makefile.am
@@ -12,7 +12,10 @@ unmunch_SOURCES=unmunch.cxx unmunch.h
example_SOURCES=example.cxx
- example_LDADD = ../hunspell/libhunspell-1.6.la
+ example_LDADD = ../hunspell/libhunspell-1.7.la
-hunspell_SOURCES=hunspell.cxx
+hunspell_CXXFLAGS = \
+ -DBINDIR=\""$(bindir)"\" \
+ -DDATA_DIR=\""$(datadir)"\"
+hunspell_SOURCES=hunspell.cxx pathtools.cxx pathtools.hxx
+ nodist_hunspell_SOURCES= ../../config.h
hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../parsers/libparsers.a \
- ../hunspell/libhunspell-1.6.la @CURSESLIB@ @READLINELIB@
-
+ ../hunspell/libhunspell-1.7.la @CURSESLIB@ @READLINELIB@
diff --git a/src/tools/hunspell.cxx b/src/tools/hunspell.cxx
index 399df86..0599794 100644
--- a/src/tools/hunspell.cxx
+++ b/src/tools/hunspell.cxx
@@ -51,6 +51,7 @@
- #include "hunspell.hxx"
- #include "csutil.hxx"
- #include "hunzip.hxx"
+ #include "../hunspell/hunspell.hxx"
+ #include "../hunspell/csutil.hxx"
+ #include "../hunspell/hunzip.hxx"
+#include "pathtools.hxx"
#define HUNSPELL_VERSION VERSION
@@ -74,19 +60,6 @@ index 399df86..0599794 100644
#define PATHSEP ";"
#ifdef __MINGW32__
-@@ -172,7 +189,12 @@ char text_conv[MAXLNLEN];
-
- #ifdef HAVE_CURSES_H
- #ifdef HAVE_NCURSESW_H
-+#ifdef __MINGW32__
-+#include <ncurses/ncurses.h>
-+#else
- #include <ncurses.h>
-+#endif //__MINGW32__
-+
- #else
- #include <curses.h>
- #endif
@@ -2042,11 +2064,20 @@ int main(int argc, char** argv) {
{
std::string path_std_str = ".";
diff --git a/PKGBUILD b/PKGBUILD
index 0bfafc1c0c37..f02ca406f9f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Sun <adsun701@gmail.com>
pkgname=mingw-w64-hunspell
-pkgver=1.6.2
+pkgver=1.7.0
pkgrel=1
pkgdesc="Spell checker and morphological analyzer library and program (mingw-w64)"
arch=(any)
@@ -12,22 +12,22 @@ depends=('mingw-w64-gettext' 'mingw-w64-ncurses' 'mingw-w64-readline')
options=(!strip !buildflags staticlibs !debug !emptydirs)
source=("hunspell-${pkgver}.tar.gz"::"https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz"
"01-relocate.patch")
-sha256sums=('3cd9ceb062fe5814f668e4f22b2fa6e3ba0b339b921739541ce180cac4d6f4c4'
- '2730c6cbca341db54f5d4a53a81c89f8e91ac6e3060af9740f5bb15185067806')
+sha256sums=('bb27b86eb910a8285407cf3ca33b62643a02798cf2eef468c0a74f6c3ee6bc8a'
+ 'b3a978749ef723481286e6237944729b6965bc57eacc5407b5f7fedf7d6aa8a1')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "${srcdir}/hunspell-${pkgver}"
-
+ cd "${srcdir}/hunspell-${pkgver}"
+
# Remove files created by patch
rm -rf src/tools/pathtools.cxx src/tools/pathtools.hxx
patch -Np1 -i ${srcdir}/01-relocate.patch
- autoreconf -fi
+ autoreconf -fiv
}
build() {
- cd hunspell-${pkgver}
+ cd "${srcdir}/hunspell-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \