summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--0001-canonicalhost.patch12
-rw-r--r--0002-exit-on-MAX_PREFIXES_SUFFIXES.patch25
-rw-r--r--0003-inc-MAX_PREFIXES_SUFFIXES-to-2048.patch14
-rw-r--r--0004-relocate.patch687
-rw-r--r--0005-windows-sub-dicts-paths.patch34
-rw-r--r--0006-Fix-for-tool-Munch-when-compiling-with-Mingw64-for-6.patch30
-rw-r--r--0007-Added-header-stddef-to-munch-and-unmunch.patch22
-rw-r--r--PKGBUILD38
-rw-r--r--hunspell-1.3.2-canonicalhost.patch11
10 files changed, 874 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a4a0f3461f4..2df51b29ee9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Aug 18 06:32:17 UTC 2016
+# Wed Sep 28 21:37:38 UTC 2016
pkgbase = mingw-w64-hunspell
pkgdesc = Spell checker and morphological analyzer library (mingw-w64)
- pkgver = 1.3.4
- pkgrel = 2
+ pkgver = 1.4.1
+ pkgrel = 1
url = http://hunspell.github.io/
arch = any
license = GPL
@@ -18,10 +18,22 @@ pkgbase = mingw-w64-hunspell
options = staticlibs
options = !debug
options = !emptydirs
- source = https://github.com/hunspell/hunspell/archive/v1.3.4.tar.gz
- source = hunspell-1.3.2-canonicalhost.patch
- md5sums = 423cff69e68c87ac11e4aa8462951954
- md5sums = f8a5c0f3692a390d98daf0406da59cdf
+ source = https://github.com/hunspell/hunspell/archive/v1.4.1.tar.gz
+ source = 0001-canonicalhost.patch
+ source = 0002-exit-on-MAX_PREFIXES_SUFFIXES.patch
+ source = 0003-inc-MAX_PREFIXES_SUFFIXES-to-2048.patch
+ source = 0004-relocate.patch
+ source = 0005-windows-sub-dicts-paths.patch
+ source = 0006-Fix-for-tool-Munch-when-compiling-with-Mingw64-for-6.patch
+ source = 0007-Added-header-stddef-to-munch-and-unmunch.patch
+ md5sums = 33d370f7fe5a030985e445a5672b2067
+ md5sums = f8b8363c7cf18b8cd26a1fa26dbdab4f
+ md5sums = 6ce08c6825e925f52bf6ff0daa64493b
+ md5sums = caf363a9c8e4df381e105db82de8a69f
+ md5sums = 26812f6444ed7c3e4ec38e12caaeb5d6
+ md5sums = 8f3f269734623b2c57521202877c51bd
+ md5sums = 748c5dcd456acb15f26c8a0c75478ae2
+ md5sums = 5477347e27495b6d19c6a60a8eaa3e19
pkgname = mingw-w64-hunspell
diff --git a/0001-canonicalhost.patch b/0001-canonicalhost.patch
new file mode 100644
index 000000000000..131969ea05f4
--- /dev/null
+++ b/0001-canonicalhost.patch
@@ -0,0 +1,12 @@
+diff -aurN 0000/configure.ac 0001/configure.ac
+--- 0000/configure.ac
++++ 0001/configure.ac
+@@ -6,7 +6,7 @@
+ AC_PREREQ(2.59)
+ AC_INIT([hunspell],[1.4.0],[nemeth@numbertext.org])
+
+-AC_CANONICAL_SYSTEM
++AC_CANONICAL_HOST
+ AC_SUBST(XFAILED)
+
+ AM_INIT_AUTOMAKE(hunspell, 1.4.0)
diff --git a/0002-exit-on-MAX_PREFIXES_SUFFIXES.patch b/0002-exit-on-MAX_PREFIXES_SUFFIXES.patch
new file mode 100644
index 000000000000..b3ff146f1f0f
--- /dev/null
+++ b/0002-exit-on-MAX_PREFIXES_SUFFIXES.patch
@@ -0,0 +1,25 @@
+diff -aurN 0001/src/tools/munch.cxx 0002/src/tools/munch.cxx
+--- 0001/src/tools/munch.cxx
++++ 0002/src/tools/munch.cxx
+@@ -361,11 +361,21 @@
+ nptr++;
+ }
+ if (ft == 'P') {
++ if (numpfx == MAX_PREFIXES) {
++ fprintf(stderr,"MAX_PREFIXES (%d) reached.",MAX_PREFIXES);
++ fprintf(stderr,"please edit value in src/tools/munch.h and rebuild hunspell\n");
++ exit(1);
++ }
+ ptable[numpfx].aep = ptr;
+ ptable[numpfx].num = numents;
+ fprintf(stderr, "ptable %d num is %d\n", numpfx, ptable[numpfx].num);
+ numpfx++;
+ } else {
++ if (numsfx == MAX_SUFFIXES) {
++ fprintf(stderr,"MAX_SUFFIXES (%d) reached.",MAX_SUFFIXES);
++ fprintf(stderr,"please edit value in src/tools/munch.h and rebuild hunspell\n");
++ exit(1);
++ }
+ stable[numsfx].aep = ptr;
+ stable[numsfx].num = numents;
+ fprintf(stderr, "stable %d num is %d\n", numsfx, stable[numsfx].num);
diff --git a/0003-inc-MAX_PREFIXES_SUFFIXES-to-2048.patch b/0003-inc-MAX_PREFIXES_SUFFIXES-to-2048.patch
new file mode 100644
index 000000000000..d258935344b1
--- /dev/null
+++ b/0003-inc-MAX_PREFIXES_SUFFIXES-to-2048.patch
@@ -0,0 +1,14 @@
+diff -aurN 0002/src/tools/munch.h 0003/src/tools/munch.h
+--- 0002/src/tools/munch.h
++++ 0003/src/tools/munch.h
+@@ -42,8 +42,8 @@
+
+ #define MAX_LN_LEN 200
+ #define MAX_WD_LEN 200
+-#define MAX_PREFIXES 256
+-#define MAX_SUFFIXES 256
++#define MAX_PREFIXES 2048
++#define MAX_SUFFIXES 2048
+ #define MAX_ROOTS 20
+ #define MAX_WORDS 5000
+
diff --git a/0004-relocate.patch b/0004-relocate.patch
new file mode 100644
index 000000000000..4bfe7fdaa9df
--- /dev/null
+++ b/0004-relocate.patch
@@ -0,0 +1,687 @@
+diff -aurN 0003/src/tools/hunspell.cxx 0004/src/tools/hunspell.cxx
+--- 0003/src/tools/hunspell.cxx
++++ 0004/src/tools/hunspell.cxx
+@@ -52,7 +52,7 @@
+ #include "config.h"
+ #include "hunspell.hxx"
+ #include "csutil.hxx"
+-
++#include "pathtools.hxx"
+ #ifndef HUNSPELL_EXTRA
+ #define suggest_auto suggest
+ #endif
+@@ -74,7 +74,15 @@
+ #define DEFAULTDICNAME "default"
+
+ #ifdef WIN32
+-
++#ifdef __MINGW32__
++#define LIBDIR \
++ DATA_DIR "/hunspell:" \
++ DATA_DIR "/myspell:" \
++ DATA_DIR "/myspell/dicts"
++#define OOODIR \
++ DATA_DIR "/dict/ooo"
++#define USEROOODIR "Application Data/OpenOffice.org 2/user/wordbook"
++#else
+ #define LIBDIR "C:\\Hunspell\\"
+ #define USEROOODIR "Application Data\\OpenOffice.org 2\\user\\wordbook"
+ #define OOODIR \
+@@ -83,11 +91,17 @@
+ "C:\\Program files\\OpenOffice.org 2.2\\share\\dict\\ooo\\;" \
+ "C:\\Program files\\OpenOffice.org 2.1\\share\\dict\\ooo\\;" \
+ "C:\\Program files\\OpenOffice.org 2.0\\share\\dict\\ooo\\"
++#endif
+ #define HOME "%USERPROFILE%\\"
+ #define DICBASENAME "hunspell_"
+ #define LOGFILE "C:\\Hunspell\\log"
++#ifdef __MINGW32__
++#define DIRSEPCH '/'
++#define DIRSEP "/"
++#else
+ #define DIRSEPCH '\\'
+ #define DIRSEP "\\"
++#endif
+ #define PATHSEP ";"
+
+ #include "textparser.hxx"
+@@ -2136,13 +2150,25 @@
+ }
+ }
+ path = add(mystrdup("."), PATHSEP); // <- check path in local directory
++#ifndef _WIN32
+ path = add(path, PATHSEP); // <- check path in root directory
++#else
++ path = add(add(path, single_path_relocation(BINDIR, BINDIR)), PATHSEP);
++#endif
+ if (getenv("DICPATH"))
+ path = add(add(path, getenv("DICPATH")), PATHSEP);
++#ifdef __MINGW32__
++ path = add(add(path, pathlist_relocation(BINDIR, LIBDIR)), PATHSEP);
++#else
+ path = add(add(path, LIBDIR), PATHSEP);
++#endif
+ if (HOME)
+ path = add(add(add(add(path, HOME), DIRSEP), USEROOODIR), PATHSEP);
++#ifdef __MINGW32__
++ path = add(path, pathlist_relocation(BINDIR, OOODIR));
++#else
+ path = add(path, OOODIR);
++#endif
+
+ if (showpath) {
+ fprintf(stderr, gettext("SEARCH PATH:\n%s\n"), path);
+diff -aurN 0003/src/tools/Makefile.am 0004/src/tools/Makefile.am
+--- 0003/src/tools/Makefile.am
++++ 0004/src/tools/Makefile.am
+@@ -12,7 +12,10 @@
+ example_SOURCES=example.cxx
+ example_LDADD = ../hunspell/libhunspell-1.4.la
+
+-hunspell_SOURCES=hunspell.cxx
++hunspell_CXXFLAGS = \
++ -DBINDIR=\""$(bindir)"\" \
++ -DDATA_DIR=\""$(datadir)"\"
++hunspell_SOURCES=hunspell.cxx pathtools.cxx pathtools.hxx
+ hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../parsers/libparsers.a \
+ ../hunspell/libhunspell-1.4.la @CURSESLIB@ @READLINELIB@
+
+diff -aurN 0003/src/tools/pathtools.cxx 0004/src/tools/pathtools.cxx
+--- 0003/src/tools/pathtools.cxx
++++ 0004/src/tools/pathtools.cxx
+@@ -0,0 +1,538 @@
++/*
++ .Some useful path tools.
++ .ASCII only for now.
++ .Written by Ray Donnelly in 2014.
++ .Licensed under CC0 (and anything.
++ .else you need to license it under).
++ .No warranties whatsoever.
++ .email: <mingw.android@gmail.com>.
++ */
++
++#if defined(__APPLE__)
++#include <stdlib.h>
++#else
++#include <malloc.h>
++#endif
++#include <limits.h>
++#include <stdio.h>
++#include <string.h>
++#if defined(__linux__) || defined(__CYGWIN__) || defined(__MSYS__)
++#include <alloca.h>
++#endif
++#include <unistd.h>
++
++/* If you don't define this, then get_executable_path()
++ can only use argv[0] which will often not work well */
++#define IMPLEMENT_SYS_GET_EXECUTABLE_PATH
++
++#if defined(IMPLEMENT_SYS_GET_EXECUTABLE_PATH)
++#if defined(__linux__) || defined(__CYGWIN__) || defined(__MSYS__)
++/* Nothing needed, unistd.h is enough. */
++#elif defined(__APPLE__)
++#include <mach-o/dyld.h>
++#elif defined(_WIN32)
++#define WIN32_MEAN_AND_LEAN
++#include <windows.h>
++#include <psapi.h>
++#endif
++#endif /* defined(IMPLEMENT_SYS_GET_EXECUTABLE_PATH) */
++
++#include "pathtools.hxx"
++
++char *
++malloc_copy_string(char const * original)
++{
++ char * result = (char *) malloc (sizeof (char*) * strlen (original)+1);
++ if (result != NULL)
++ {
++ strcpy (result, original);
++ }
++ return result;
++}
++
++void
++sanitise_path(char * path)
++{
++ size_t path_size = strlen (path);
++
++ /* Replace any '\' with '/' */
++ char * path_p = path;
++ while ((path_p = strchr (path_p, '\\')) != NULL)
++ {
++ *path_p = '/';
++ }
++ /* Replace any '//' with '/' */
++ path_p = path;
++ while ((path_p = strstr (path_p, "//")) != NULL)
++ {
++ memmove (path_p, path_p + 1, path_size--);
++ }
++ return;
++}
++
++char *
++get_relative_path(char const * from_in, char const * to_in)
++{
++ size_t from_size = (from_in == NULL) ? 0 : strlen (from_in);
++ size_t to_size = (to_in == NULL) ? 0 : strlen (to_in);
++ size_t max_size = (from_size + to_size) * 2 + 4;
++ char * scratch_space = (char *) alloca (from_size + 1 + to_size + 1 + max_size + max_size);
++ char * from;
++ char * to;
++ char * common_part;
++ char * result;
++ size_t count;
++
++ /* No to, return "./" */
++ if (to_in == NULL)
++ {
++ return malloc_copy_string ("./");
++ }
++
++ /* If alloca failed or no from was given return a copy of to */
++ if ( from_in == NULL
++ || scratch_space == NULL )
++ {
++ return malloc_copy_string (to_in);
++ }
++
++ from = scratch_space;
++ strcpy (from, from_in);
++ to = from + from_size + 1;
++ strcpy (to, to_in);
++ common_part = to + to_size + 1;
++ result = common_part + max_size;
++ simplify_path (from);
++ simplify_path (to);
++
++ result[0] = '\0';
++
++ size_t match_size_dirsep = 0; /* The match size up to the last /. Always wind back to this - 1 */
++ size_t match_size = 0; /* The running (and final) match size. */
++ size_t largest_size = (from_size > to_size) ? from_size : to_size;
++ int to_final_is_slash = (to[to_size-1] == '/') ? 1 : 0;
++ char from_c;
++ char to_c;
++ for (match_size = 0; match_size < largest_size; ++match_size)
++ {
++ /* To simplify the logic, always pretend the strings end with '/' */
++ from_c = (match_size < from_size) ? from[match_size] : '/';
++ to_c = (match_size < to_size) ? to[match_size] : '/';
++
++ if (from_c != to_c)
++ {
++ if (from_c != '\0' || to_c != '\0')
++ {
++ match_size = match_size_dirsep;
++ }
++ break;
++ }
++ else if (from_c == '/')
++ {
++ match_size_dirsep = match_size;
++ }
++ }
++ strncpy (common_part, from, match_size);
++ common_part[match_size] = '\0';
++ from += match_size;
++ to += match_size;
++ size_t ndotdots = 0;
++ char const* from_last = from + strlen(from) - 1;
++ while ((from = strchr (from, '/')) && from != from_last)
++ {
++ ++ndotdots;
++ ++from;
++ }
++ for (count = 0; count < ndotdots; ++count)
++ {
++ strcat(result, "../");
++ }
++ if (strlen(to) > 0)
++ {
++ strcat(result, to+1);
++ }
++ /* Make sure that if to ends with '/' result does the same, and
++ vice-versa. */
++ size_t size_result = strlen(result);
++ if ((to_final_is_slash == 1)
++ && (!size_result || result[size_result-1] != '/'))
++ {
++ strcat (result, "/");
++ }
++ else if (!to_final_is_slash
++ && size_result && result[size_result-1] == '/')
++ {
++ result[size_result-1] = '\0';
++ }
++
++ return malloc_copy_string (result);
++}
++
++void
++simplify_path(char * path)
++{
++ ssize_t n_toks = 1; /* in-case we need an empty initial token. */
++ ssize_t i, j;
++ size_t tok_size;
++ size_t in_size = strlen (path);
++ int it_ended_with_a_slash = (path[in_size - 1] == '/') ? 1 : 0;
++ char * result = path;
++ sanitise_path(result);
++ char * result_p = result;
++
++ do
++ {
++ ++n_toks;
++ ++result_p;
++ } while ((result_p = strchr (result_p, '/')) != NULL);
++
++ result_p = result;
++ char const ** toks = (char const **) alloca (sizeof (char const*) * n_toks);
++ n_toks = 0;
++ do
++ {
++ if (result_p > result)
++ {
++ *result_p++ = '\0';
++ }
++ else if (*result_p == '/')
++ {
++ /* A leading / creates an empty initial token. */
++ toks[n_toks++] = result_p;
++ *result_p++ = '\0';
++ }
++ toks[n_toks++] = result_p;
++ } while ((result_p = strchr (result_p, '/')) != NULL);
++
++ /* Remove all non-leading '.' and any '..' we can match
++ with an earlier forward path (i.e. neither '.' nor '..') */
++ for (i = 1; i < n_toks; ++i)
++ {
++ int removals[2] = { -1, -1 };
++ if ( strcmp (toks[i], "." ) == 0)
++ {
++ removals[0] = i;
++ }
++ else if ( strcmp (toks[i], ".." ) == 0)
++ {
++ /* Search backwards for a forward path to collapse.
++ If none are found then the .. also stays. */
++ for (j = i - 1; j > -1; --j)
++ {
++ if ( strcmp (toks[j], "." )
++ && strcmp (toks[j], ".." ) )
++ {
++ removals[0] = j;
++ removals[1] = i;
++ break;
++ }
++ }
++ }
++ for (j = 0; j < 2; ++j)
++ {
++ if (removals[j] >= 0) /* Can become -2 */
++ {
++ --n_toks;
++ memmove (&toks[removals[j]], &toks[removals[j]+1], (n_toks - removals[j])*sizeof (char*));
++ --i;
++ if (!j)
++ {
++ --removals[1];
++ }
++ }
++ }
++ }
++ result_p = result;
++ for (i = 0; i < n_toks; ++i)
++ {
++ tok_size = strlen(toks[i]);
++ memcpy (result_p, toks[i], tok_size);
++ result_p += tok_size;
++ if ((!i || tok_size) && ((i < n_toks - 1) || it_ended_with_a_slash == 1))
++ {
++ *result_p = '/';
++ ++result_p;
++ }
++ }
++ *result_p = '\0';
++}
++
++/* Returns actual_to by calculating the relative path from -> to and
++ applying that to actual_from. An assumption that actual_from is a
++ dir is made, and it may or may not end with a '/' */
++char const *
++get_relocated_path (char const * from, char const * to, char const * actual_from)
++{
++ char const * relative_from_to = get_relative_path (from, to);
++ char * actual_to = (char *) malloc (strlen(actual_from) + 2 + strlen(relative_from_to));
++ return actual_to;
++}
++
++int
++get_executable_path(char const * argv0, char * result, ssize_t max_size)
++{
++ char * system_result = (char *) alloca (max_size);
++ ssize_t system_result_size = -1;
++ ssize_t result_size = -1;
++
++ if (system_result != NULL)
++ {
++#if defined(IMPLEMENT_SYS_GET_EXECUTABLE_PATH)
++#if defined(__linux__) || defined(__CYGWIN__) || defined(__MSYS__)
++ system_result_size = readlink("/proc/self/exe", system_result, max_size);
++#elif defined(__APPLE__)
++ uint32_t bufsize = (uint32_t)max_size;
++ if (_NSGetExecutablePath(system_result, &bufsize) == 0)
++ {
++ system_result_size = (ssize_t)bufsize;
++ }
++#elif defined(_WIN32)
++ unsigned long bufsize = (unsigned long)max_size;
++ system_result_size = GetModuleFileNameA(NULL, system_result, bufsize);
++ if (system_result_size == 0 || system_result_size == (ssize_t)bufsize)
++ {
++ /* Error, possibly not enough space. */
++ system_result_size = -1;
++ }
++ else
++ {
++ /* Early conversion to unix slashes instead of more changes
++ everywhere else .. */
++ char * winslash;
++ system_result[system_result_size] = '\0';
++ while ((winslash = strchr (system_result, '\\')) != NULL)
++ {
++ *winslash = '/';
++ }
++ }
++#else
++#warning "Don't know how to get executable path on this system"
++#endif
++#endif /* defined(IMPLEMENT_SYS_GET_EXECUTABLE_PATH) */
++ }
++ /* Use argv0 as a default in-case of failure */
++ if (system_result_size != -1)
++ {
++ strncpy (result, system_result, system_result_size);
++ result[system_result_size] = '\0';
++ }
++ else
++ {
++ if (argv0 != NULL)
++ {
++ strncpy (result, argv0, max_size);
++ result[max_size-1] = '\0';
++ }
++ else
++ {
++ result[0] = '\0';
++ }
++ }
++ result_size = strlen (result);
++ return result_size;
++}
++
++char const *
++strip_n_prefix_folders(char const * path, size_t n)
++{
++ if (path == NULL)
++ {
++ return NULL;
++ }
++
++ if (path[0] != '/')
++ {
++ return path;
++ }
++
++ char const * last = path;
++ while (n-- && path != NULL)
++ {
++ last = path;
++ path = strchr (path + 1, '/');
++ }
++ return (path == NULL) ? last : path;
++}
++
++void
++strip_n_suffix_folders(char * path, size_t n)
++{
++ if (path == NULL)
++ {
++ return;
++ }
++ while (n--)
++ {
++ if (strrchr (path + 1, '/'))
++ {
++ *strrchr (path + 1, '/') = '\0';
++ }
++ else
++ {
++ return;
++ }
++ }
++ return;
++}
++
++size_t
++split_path_list(char const * path_list, char split_char, char *** arr)
++{
++ size_t path_count;
++ size_t path_list_size;
++ char const * path_list_p;
++
++ path_list_p = path_list;
++ if (path_list == NULL || path_list[0] == '\0')
++ {
++ return 0;
++ }
++ path_list_size = strlen (path_list);
++
++ path_count = 0;
++ do
++ {
++ ++path_count;
++ ++path_list_p;
++ }
++ while ((path_list_p = strchr (path_list_p, split_char)) != NULL);
++
++ /* allocate everything in one go. */
++ char * all_memory = (char *) malloc (sizeof (char *) * path_count + strlen(path_list) + 1);
++ if (all_memory == NULL)
++ return 0;
++ *arr = (char **)all_memory;
++ all_memory += sizeof (char *) * path_count;
++
++ path_count = 0;
++ path_list_p = path_list;
++ char const * next_path_list_p = 0;
++ do
++ {
++ next_path_list_p = strchr (path_list_p, split_char);
++ if (next_path_list_p != NULL)
++ {
++ ++next_path_list_p;
++ }
++ size_t this_size = (next_path_list_p != NULL)
++ ? next_path_list_p - path_list_p - 1
++ : &path_list[path_list_size] - path_list_p;
++ memcpy (all_memory, path_list_p, this_size);
++ all_memory[this_size] = '\0';
++ (*arr)[path_count++] = all_memory;
++ all_memory += this_size + 1;
++ } while ((path_list_p = next_path_list_p) != NULL);
++
++ return path_count;
++}
++
++char *
++get_relocated_path_list(char const * from, char const * to_path_list)
++{
++ char exe_path[MAX_PATH];
++ char * temp;
++ get_executable_path (NULL, &exe_path[0], sizeof (exe_path) / sizeof (exe_path[0]));
++ if ((temp = strrchr (exe_path, '/')) != NULL)
++ {
++ temp[1] = '\0';
++ }
++
++ char **arr = NULL;
++ /* Ask Alexey why he added this. Are we not 100% sure
++ that we're dealing with unix paths here? */
++ char split_char = ':';
++ if (strchr (to_path_list, ';'))
++ {
++ split_char = ';';
++ }
++ size_t count = split_path_list (to_path_list, split_char, &arr);
++ int result_size = 1 + (count - 1); /* count - 1 is for ; delim. */
++ size_t exe_path_size = strlen (exe_path);
++ size_t i;
++ /* Space required is:
++ count * (exe_path_size + strlen (rel_to_datadir))
++ rel_to_datadir upper bound is:
++ (count * strlen (from)) + (3 * num_slashes (from))
++ + strlen(arr[i]) + 1.
++ .. pathalogically num_slashes (from) is strlen (from)
++ (from = ////////) */
++ size_t space_required = (count * (exe_path_size + 4 * strlen (from))) + count - 1;
++ for (i = 0; i < count; ++i)
++ {
++ space_required += strlen (arr[i]);
++ }
++ char * scratch = (char *) alloca (space_required);
++ if (scratch == NULL)
++ return NULL;
++ for (i = 0; i < count; ++i)
++ {
++ char * rel_to_datadir = get_relative_path (from, arr[i]);
++ scratch[0] = '\0';
++ arr[i] = scratch;
++ strcat (scratch, exe_path);
++ strcat (scratch, rel_to_datadir);
++ simplify_path (arr[i]);
++ size_t arr_i_size = strlen (arr[i]);
++ result_size += arr_i_size;
++ scratch = arr[i] + arr_i_size + 1;
++ }
++ char * result = (char *) malloc (result_size);
++ if (result == NULL)
++ {
++ return NULL;
++ }
++ result[0] = '\0';
++ for (i = 0; i < count; ++i)
++ {
++ strcat (result, arr[i]);
++ if (i != count-1)
++ {
++#if defined(_WIN32)
++ strcat (result, ";");
++#else
++ strcat (result, ":");
++#endif
++ }
++ }
++ free ((void*)arr);
++ return result;
++}
++
++char *
++single_path_relocation(const char *from, const char *to)
++{
++#if defined(__MINGW32__)
++ char exe_path[PATH_MAX];
++ get_executable_path (NULL, &exe_path[0], sizeof(exe_path)/sizeof(exe_path[0]));
++ if (strrchr (exe_path, '/') != NULL)
++ {
++ strrchr (exe_path, '/')[1] = '\0';
++ }
++ char * rel_to_datadir = get_relative_path (from, to);
++ strcat (exe_path, rel_to_datadir);
++ simplify_path (&exe_path[0]);
++ return malloc_copy_string(exe_path);
++#else
++ return malloc_copy_string(to);
++#endif
++}
++
++char *
++pathlist_relocation(const char *from_path, const char *to_path_list)
++{
++#if defined(__MINGW32__)
++ static char stored_path[PATH_MAX];
++ static int stored = 0;
++ if (stored == 0)
++ {
++ char const * relocated = get_relocated_path_list(from_path, to_path_list);
++ strncpy (stored_path, relocated, PATH_MAX);
++ stored_path[PATH_MAX-1] = '\0';
++ free ((void *)relocated);
++ stored = 1;
++ }
++ return stored_path;
++#else
++ return (to_path_list);
++#endif
++}
+diff -aurN 0003/src/tools/pathtools.hxx 0004/src/tools/pathtools.hxx
+--- 0003/src/tools/pathtools.hxx
++++ 0004/src/tools/pathtools.hxx
+@@ -0,0 +1,53 @@
++/*
++ .Some useful path tools.
++ .ASCII only for now.
++ .Written by Ray Donnelly in 2014.
++ .Licensed under CC0 (and anything.
++ .else you need to license it under).
++ .No warranties whatsoever.
++ .email: <mingw.android@gmail.com>.
++ */
++
++#ifndef PATHTOOLS_H
++#define PATHTOOLS_H
++
++#include <unistd.h>
++#if defined(__APPLE__)
++#include <stdlib.h>
++#else
++#include <malloc.h>
++#endif
++#include <stdio.h>
++
++char * malloc_copy_string(char const * original);
++
++/* In-place replaces any '\' with '/' and any '//' with '/' */
++void sanitise_path(char * path);
++
++/* Uses a host OS specific function to determine the path of the executable,
++ if IMPLEMENT_SYS_GET_EXECUTABLE_PATH is defined, otherwise uses argv0. */
++int get_executable_path(char const * argv0, char * result, ssize_t max_size);
++
++/* Where possible, in-place removes occourances of '.' and 'path/..' */
++void simplify_path(char * path);
++
++/* Allocates (via malloc) and returns the path to get from from to to. */
++char * get_relative_path(char const * from, char const * to);
++
++size_t split_path_list(char const * path_list, char split_char, char *** arr);
++
++/* Advances path along by the amount that removes n prefix folders. */
++char const *
++strip_n_prefix_folders(char const * path, size_t n);
++
++/* NULL terminates path to remove n suffix folders. */
++void
++strip_n_suffix_folders(char * path, size_t n);
++
++char const * get_relocated_path (char const * from, char const * to, char const * actual_from);
++char * get_relocated_path_list(char const * from, char const * to_path_list);
++
++char * single_path_relocation(const char *from, const char *to);
++char * pathlist_relocation(const char *from_path, const char *to_path_list);
++
++#endif /* PATHTOOLS_H */
diff --git a/0005-windows-sub-dicts-paths.patch b/0005-windows-sub-dicts-paths.patch
new file mode 100644
index 000000000000..6887b2df99d7
--- /dev/null
+++ b/0005-windows-sub-dicts-paths.patch
@@ -0,0 +1,34 @@
+diff -aurN 0004/src/tools/hunspell.cxx 0005/src/tools/hunspell.cxx
+--- 0004/src/tools/hunspell.cxx
++++ 0005/src/tools/hunspell.cxx
+@@ -104,6 +104,12 @@
+ #endif
+ #define PATHSEP ";"
+
++#ifdef __MINGW32__
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <dirent.h>
++#include <unistd.h>
++#endif
+ #include "textparser.hxx"
+ #include "htmlparser.hxx"
+ #include "latexparser.hxx"
+@@ -1812,7 +1818,7 @@
+ return NULL;
+ }
+
+-#ifndef WIN32
++#if !defined(WIN32) || defined(__MINGW32__)
+ int listdicpath(char* dir, int len) {
+ std::string buf;
+ const char* sep = (len == 0) ? "" : DIRSEP;
+@@ -1847,7 +1853,7 @@
+ if (name) {
+ res = exist2(begin, end - begin, name, ext);
+ } else {
+-#ifndef WIN32
++#if !defined(WIN32) || defined(__MINGW32__)
+ listdicpath(begin, end - begin);
+ #endif
+ }
diff --git a/0006-Fix-for-tool-Munch-when-compiling-with-Mingw64-for-6.patch b/0006-Fix-for-tool-Munch-when-compiling-with-Mingw64-for-6.patch
new file mode 100644
index 000000000000..983284f1bdc5
--- /dev/null
+++ b/0006-Fix-for-tool-Munch-when-compiling-with-Mingw64-for-6.patch
@@ -0,0 +1,30 @@
+diff -aurN 0005/src/tools/munch.cxx 0006/src/tools/munch.cxx
+--- 0005/src/tools/munch.cxx
++++ 0006/src/tools/munch.cxx
+@@ -839,9 +839,9 @@
+ if (n > 0) {
+ char* dp = (char*)memchr(mp, (int)((unsigned char)delim), n);
+ if (dp) {
+- int nc;
++ ptrdiff_t nc;
+ *stringp = dp + 1;
+- nc = (int)((unsigned long)dp - (unsigned long)mp);
++ nc = dp - mp;
+ rv = (char*)malloc(nc + 1);
+ if (rv) {
+ memcpy(rv, mp, nc);
+diff -aurN 0005/src/tools/unmunch.cxx 0006/src/tools/unmunch.cxx
+--- 0005/src/tools/unmunch.cxx
++++ 0006/src/tools/unmunch.cxx
+@@ -516,9 +516,9 @@
+ if (n > 0) {
+ char* dp = (char*)memchr(mp, (int)((unsigned char)delim), n);
+ if (dp) {
+- int nc;
++ ptrdiff_t nc;
+ *stringp = dp + 1;
+- nc = (int)((unsigned long)dp - (unsigned long)mp);
++ nc = dp - mp;
+ rv = (char*)malloc(nc + 1);
+ if (rv) {
+ memcpy(rv, mp, nc);
diff --git a/0007-Added-header-stddef-to-munch-and-unmunch.patch b/0007-Added-header-stddef-to-munch-and-unmunch.patch
new file mode 100644
index 000000000000..bb9f999e5414
--- /dev/null
+++ b/0007-Added-header-stddef-to-munch-and-unmunch.patch
@@ -0,0 +1,22 @@
+diff -aurN 0006/src/tools/munch.cxx 0007/src/tools/munch.cxx
+--- 0006/src/tools/munch.cxx
++++ 0007/src/tools/munch.cxx
+@@ -47,6 +47,7 @@
+ #include <stdlib.h>
+ #include <stdint.h>
+ #include <stdio.h>
++#include <stddef.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+diff -aurN 0006/src/tools/unmunch.cxx 0007/src/tools/unmunch.cxx
+--- 0006/src/tools/unmunch.cxx
++++ 0007/src/tools/unmunch.cxx
+@@ -49,6 +49,7 @@
+ #include <stdlib.h>
+ #include <stdint.h>
+ #include <stdio.h>
++#include <stddef.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
diff --git a/PKGBUILD b/PKGBUILD
index fef6630b879e..3d1eaa9561a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-hunspell
-pkgver=1.3.4
-pkgrel=2
+pkgver=1.4.1
+pkgrel=1
pkgdesc="Spell checker and morphological analyzer library (mingw-w64)"
arch=(any)
url="http://hunspell.github.io/"
@@ -10,15 +10,38 @@ depends=(mingw-w64-gettext)
optdepends=(mingw-w64-readline)
options=(!strip !buildflags staticlibs !debug !emptydirs)
source=("https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz"
-"hunspell-1.3.2-canonicalhost.patch")
-md5sums=('423cff69e68c87ac11e4aa8462951954'
- 'f8a5c0f3692a390d98daf0406da59cdf')
+"0001-canonicalhost.patch"
+"0002-exit-on-MAX_PREFIXES_SUFFIXES.patch"
+"0003-inc-MAX_PREFIXES_SUFFIXES-to-2048.patch"
+"0004-relocate.patch"
+"0005-windows-sub-dicts-paths.patch"
+"0006-Fix-for-tool-Munch-when-compiling-with-Mingw64-for-6.patch"
+"0007-Added-header-stddef-to-munch-and-unmunch.patch")
+md5sums=('33d370f7fe5a030985e445a5672b2067'
+ 'f8b8363c7cf18b8cd26a1fa26dbdab4f'
+ '6ce08c6825e925f52bf6ff0daa64493b'
+ 'caf363a9c8e4df381e105db82de8a69f'
+ '26812f6444ed7c3e4ec38e12caaeb5d6'
+ '8f3f269734623b2c57521202877c51bd'
+ '748c5dcd456acb15f26c8a0c75478ae2'
+ '5477347e27495b6d19c6a60a8eaa3e19')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd hunspell-${pkgver}
- patch -Np1 -i "$srcdir"/hunspell-1.3.2-canonicalhost.patch
+ #remove files created by patch
+ rm -rf src/tools/pathtools.cxx src/tools/pathtools.hxx
+ patch -Np1 -i "${srcdir}"/0001-canonicalhost.patch
+ patch -Np1 -i "${srcdir}"/0002-exit-on-MAX_PREFIXES_SUFFIXES.patch
+ patch -Np1 -i "${srcdir}"/0003-inc-MAX_PREFIXES_SUFFIXES-to-2048.patch
+ patch -Np1 -i "${srcdir}"/0004-relocate.patch
+ patch -Np1 -i "${srcdir}"/0005-windows-sub-dicts-paths.patch
+
+ # See https://github.com/hunspell/hunspell/pull/389
+ patch -Np1 -i "${srcdir}"/0006-Fix-for-tool-Munch-when-compiling-with-Mingw64-for-6.patch
+ patch -Np1 -i "${srcdir}"/0007-Added-header-stddef-to-munch-and-unmunch.patch
+
autoreconf -fi
}
@@ -29,7 +52,8 @@ build() {
${_arch}-configure \
--disable-rpath \
--enable-threads=win32 \
- --without-ui
+ --with-ui \
+ --with-readline
# temporarily copy hunvisapi.h to work around build process
# where the file is not spotted.
cp ${srcdir}/hunspell-${pkgver}/build-${_arch}/src/hunspell/hunvisapi.h \
diff --git a/hunspell-1.3.2-canonicalhost.patch b/hunspell-1.3.2-canonicalhost.patch
deleted file mode 100644
index 959b59d4ff59..000000000000
--- a/hunspell-1.3.2-canonicalhost.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- hunspell-1.3.2/configure.ac 2011-02-16 15:41:44.000000000 +0100
-+++ hunspell-1.3.2/configure.ac 2012-09-07 08:56:36.670836839 +0200
-@@ -6,7 +6,7 @@
- AC_PREREQ(2.59)
- AC_INIT([hunspell],[1.3.2],[nemeth@numbertext.org])
-
--AC_CANONICAL_SYSTEM
-+AC_CANONICAL_HOST
- AC_SUBST(XFAILED)
-
- AM_INIT_AUTOMAKE(hunspell, 1.3.2)