summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--02-fix-link-with-pdcurses.patch18
-rw-r--r--PKGBUILD16
3 files changed, 33 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a50b5607fa9e..b4bae53b1fd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-hunspell
pkgdesc = Spell checker and morphological analyzer library and program (mingw-w64)
pkgver = 1.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://hunspell.github.io/
arch = any
license = GPL
@@ -11,7 +11,7 @@ pkgbase = mingw-w64-hunspell
makedepends = mingw-w64-readline
makedepends = mingw-w64-wine
depends = mingw-w64-gettext
- depends = mingw-w64-ncurses
+ depends = mingw-w64-pdcurses
depends = mingw-w64-readline
options = !strip
options = !buildflags
@@ -20,8 +20,10 @@ pkgbase = mingw-w64-hunspell
options = !emptydirs
source = hunspell-1.7.0.tar.gz::https://github.com/hunspell/hunspell/archive/v1.7.0.tar.gz
source = 01-relocate.patch
+ source = 02-fix-link-with-pdcurses.patch
sha256sums = bb27b86eb910a8285407cf3ca33b62643a02798cf2eef468c0a74f6c3ee6bc8a
sha256sums = b3a978749ef723481286e6237944729b6965bc57eacc5407b5f7fedf7d6aa8a1
+ sha256sums = 260432a8f01525e83124c79e375cc9f0692b1a6c97773add4c69b8efe081cf1d
pkgname = mingw-w64-hunspell
diff --git a/02-fix-link-with-pdcurses.patch b/02-fix-link-with-pdcurses.patch
new file mode 100644
index 000000000000..e7230875d9b4
--- /dev/null
+++ b/02-fix-link-with-pdcurses.patch
@@ -0,0 +1,18 @@
+--- hunspell-1.7.0/configure.ac.orig 2019-05-28 10:02:21.550919600 +0300
++++ hunspell-1.7.0/configure.ac 2019-05-28 10:04:50.211127700 +0300
+@@ -80,11 +80,13 @@
+ AS_IF([test "x$with_readline" != xno],
+ [AC_CHECK_LIB([tinfo],[tgetent], [
+ TERMLIB=-ltinfo
+- ],[AC_CHECK_LIB([curses],[tparm],[
++ ],[AC_CHECK_LIB([ncurses],[tparm],[
+ TERMLIB=-lncurses
++ ],[AC_CHECK_LIB([curses],[tparm],[
++ TERMLIB=-lcurses
+ ],[AC_CHECK_LIB([termcap],[tgetent],[
+ TERMLIB=-ltermcap
+- ])])])
++ ])])])])
+ LDSAVE=$LDFLAGS
+ LDFLAGS="$LDFLAGS $TERMLIB"
+ AC_CHECK_LIB([readline],[readline],[
diff --git a/PKGBUILD b/PKGBUILD
index f02ca406f9f1..d62cdcb1f1f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,20 @@
pkgname=mingw-w64-hunspell
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="Spell checker and morphological analyzer library and program (mingw-w64)"
arch=(any)
url="https://hunspell.github.io/"
license=("GPL" "LGPL" "MPL")
makedepends=('mingw-w64-configure' 'mingw-w64-readline' 'mingw-w64-wine')
-depends=('mingw-w64-gettext' 'mingw-w64-ncurses' 'mingw-w64-readline')
+depends=('mingw-w64-gettext' 'mingw-w64-pdcurses' 'mingw-w64-readline')
options=(!strip !buildflags staticlibs !debug !emptydirs)
source=("hunspell-${pkgver}.tar.gz"::"https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz"
- "01-relocate.patch")
+ "01-relocate.patch"
+ "02-fix-link-with-pdcurses.patch")
sha256sums=('bb27b86eb910a8285407cf3ca33b62643a02798cf2eef468c0a74f6c3ee6bc8a'
- 'b3a978749ef723481286e6237944729b6965bc57eacc5407b5f7fedf7d6aa8a1')
+ 'b3a978749ef723481286e6237944729b6965bc57eacc5407b5f7fedf7d6aa8a1'
+ '260432a8f01525e83124c79e375cc9f0692b1a6c97773add4c69b8efe081cf1d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -23,16 +25,20 @@ prepare() {
# Remove files created by patch
rm -rf src/tools/pathtools.cxx src/tools/pathtools.hxx
patch -Np1 -i ${srcdir}/01-relocate.patch
+ patch -Np1 -i ${srcdir}/02-fix-link-with-pdcurses.patch
autoreconf -fiv
}
build() {
cd "${srcdir}/hunspell-${pkgver}"
for _arch in ${_architectures}; do
+ CPPFLAGS+=" -I/usr/${_arch}/include/pdcurses"
+ CFLAGS+=" -I/usr/${_arch}/include/pdcurses"
+ CXXFLAGS+=" -I/usr/${_arch}/include/pdcurses"
+
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \
--disable-rpath \
- --enable-threads=win32 \
--with-ui \
--with-readline
make