summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4960216a75b..1735a008b77c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-hwloc
pkgdesc = Portable Hardware Locality is a portable abstraction of hierarchical architectures (mingw-w64)
- pkgver = 2.5.0
+ pkgver = 2.10.0
pkgrel = 1
url = https://www.open-mpi.org/projects/hwloc/
arch = any
@@ -10,7 +10,7 @@ pkgbase = mingw-w64-hwloc
options = !buildflags
options = staticlibs
options = !strip
- source = https://www.open-mpi.org/software/hwloc/v2.5/downloads/hwloc-2.5.0.tar.bz2
- sha256sums = a9cf9088be085bdd167c78b73ddf94d968fa73a8ccf62172481ba9342c4f52c8
+ source = https://www.open-mpi.org/software/hwloc/v2.10/downloads/hwloc-2.10.0.tar.bz2
+ sha256sums = 0305dd60c9de2fbe6519fe2a4e8fdc6d3db8de574a0ca7812b92e80c05ae1392
pkgname = mingw-w64-hwloc
diff --git a/PKGBUILD b/PKGBUILD
index a13a31b77454..5ef629d99376 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-hwloc
-pkgver=2.5.0
+pkgver=2.10.0
pkgrel=1
pkgdesc='Portable Hardware Locality is a portable abstraction of hierarchical architectures (mingw-w64)'
url='https://www.open-mpi.org/projects/hwloc/'
@@ -9,21 +9,21 @@ depends=('mingw-w64-libxml2')
makedepends=('mingw-w64-configure')
options=('!buildflags' 'staticlibs' '!strip')
source=("https://www.open-mpi.org/software/hwloc/v${pkgver%.*}/downloads/hwloc-${pkgver}.tar.bz2")
-sha256sums=('a9cf9088be085bdd167c78b73ddf94d968fa73a8ccf62172481ba9342c4f52c8')
+sha256sums=('0305dd60c9de2fbe6519fe2a4e8fdc6d3db8de574a0ca7812b92e80c05ae1392')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd hwloc-${pkgver}
- sed -i "161,163d" utils/hwloc/Makefile.am
- autoreconf -fiv
-}
+#prepare() {
+# cd hwloc-${pkgver}
+# sed -i "161,163d" utils/hwloc/Makefile.am
+# autoreconf -fiv
+#}
build() {
cd hwloc-${pkgver}
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure --disable-netloc ..
+ ${_arch}-configure ..
make
popd
done