summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3361bf0f91fb..7f720947eda0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
# Generated by mksrcinfo v8
-# Fri Oct 14 16:17:50 UTC 2016
+# Tue Mar 7 12:25:59 UTC 2017
pkgbase = mingw-w64-libepoxy
pkgdesc = A library for handling OpenGL function pointer management for you (mingw-w64)
- pkgver = 1.3.1
- pkgrel = 3
+ pkgver = 1.4.1
+ pkgrel = 1
url = https://github.com/anholt/libepoxy
arch = any
license = MIT
makedepends = mingw-w64-gcc
makedepends = mingw-w64-configure
+ makedepends = python
+ makedepends = xorg-util-macros
depends = mingw-w64-crt
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/anholt/libepoxy/releases/download/v1.3.1/libepoxy-1.3.1.tar.bz2
- sha256sums = 1d8668b0a259c709899e1c4bab62d756d9002d546ce4f59c9665e2fc5f001a64
+ source = libepoxy-1.4.1.tar.gz::https://github.com/anholt/libepoxy/archive/1.4.1.tar.gz
+ sha256sums = da8f42c355b62c2c3ff6bc534c2a24099707b249c2af6eaf8db54b94c364a504
pkgname = mingw-w64-libepoxy
diff --git a/PKGBUILD b/PKGBUILD
index 5a9d08c19285..8e433e3bb38d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
# Maintainer: lantw44 at gmail dot com
pkgname=mingw-w64-libepoxy
-pkgver=1.3.1
-pkgrel=3
+pkgver=1.4.1
+pkgrel=1
pkgdesc="A library for handling OpenGL function pointer management for you (mingw-w64)"
arch=(any)
url="https://github.com/anholt/libepoxy"
license=('MIT')
makedepends=(
'mingw-w64-gcc'
- 'mingw-w64-configure')
+ 'mingw-w64-configure'
+ 'python'
+ 'xorg-util-macros')
depends=(
'mingw-w64-crt')
options=(!strip !buildflags staticlibs)
-source=("https://github.com/anholt/libepoxy/releases/download/v${pkgver}/libepoxy-${pkgver}.tar.bz2")
-sha256sums=('1d8668b0a259c709899e1c4bab62d756d9002d546ce4f59c9665e2fc5f001a64')
+source=("libepoxy-${pkgver}.tar.gz::https://github.com/anholt/libepoxy/archive/${pkgver}.tar.gz")
+sha256sums=('da8f42c355b62c2c3ff6bc534c2a24099707b249c2af6eaf8db54b94c364a504')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/libepoxy-${pkgver}"
+ NOCONFIGURE=1 ./autogen.sh
for _arch in ${_architectures}; do
mkdir -p "build-${_arch}"
cd "build-${_arch}"