summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
-rw-r--r--libidn2-mingw.patch95
3 files changed, 9 insertions, 108 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ed34ab55cbe..01825d6878a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Aug 17 17:55:56 UTC 2017
pkgbase = mingw-w64-libidn2
pkgdesc = A free software implementation of IDNA2008 (mingw-w64)
- pkgver = 2.0.3
+ pkgver = 2.3.7
pkgrel = 1
url = http://www.gnu.org/software/libidn
arch = any
@@ -13,10 +11,7 @@ pkgbase = mingw-w64-libidn2
options = staticlibs
options = !strip
options = !buildflags
- source = https://ftp.gnu.org/pub/gnu/libidn/libidn2-2.0.3.tar.gz
- source = libidn2-mingw.patch
- sha1sums = 9264dfafbad5979a9b38d8092e9f3fe6481843ea
- sha1sums = SKIP
+ source = https://ftp.gnu.org/pub/gnu/libidn/libidn2-2.3.7.tar.gz
+ sha256sums = 4c21a791b610b9519b9d0e12b8097bf2f359b12f8dd92647611a929e6bfd7d64
pkgname = mingw-w64-libidn2
-
diff --git a/PKGBUILD b/PKGBUILD
index fbb1ab9b0550..5499ad37ff4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
+# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-libidn2
-pkgver=2.0.3
+pkgver=2.3.7
pkgrel=1
pkgdesc="A free software implementation of IDNA2008 (mingw-w64)"
arch=(any)
@@ -8,10 +9,8 @@ license=("GPL3, LGPL3")
makedepends=(mingw-w64-configure)
depends=(mingw-w64-crt mingw-w64-libunistring)
options=(staticlibs !strip !buildflags)
-source=("https://ftp.gnu.org/pub/gnu/libidn/libidn2-${pkgver}.tar.gz"
- libidn2-mingw.patch)
-sha1sums=('9264dfafbad5979a9b38d8092e9f3fe6481843ea'
- 'SKIP')
+source=("https://ftp.gnu.org/pub/gnu/libidn/libidn2-${pkgver}.tar.gz")
+sha256sums=('4c21a791b610b9519b9d0e12b8097bf2f359b12f8dd92647611a929e6bfd7d64')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -34,3 +33,5 @@ package() {
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}
+
+# vim: ts=2 sw=2 et:
diff --git a/libidn2-mingw.patch b/libidn2-mingw.patch
deleted file mode 100644
index 173100af1fc1..000000000000
--- a/libidn2-mingw.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-diff -ur libidn2-0.16.orig/src/idn2.c libidn2-0.16/src/idn2.c
---- libidn2-0.16.orig/src/idn2.c 2017-02-06 18:33:44.840135786 +0100
-+++ libidn2-0.16/src/idn2.c 2017-02-06 18:59:32.753490461 +0100
-@@ -42,6 +42,68 @@
-
- #include "blurbs.h"
-
-+
-+size_t getline(char **lineptr, size_t *n, FILE *stream) {
-+ char *bufptr = NULL;
-+ char *p = bufptr;
-+ size_t size;
-+ int c;
-+
-+ if (lineptr == NULL) {
-+ return -1;
-+ }
-+ if (stream == NULL) {
-+ return -1;
-+ }
-+ if (n == NULL) {
-+ return -1;
-+ }
-+ bufptr = *lineptr;
-+ size = *n;
-+
-+ c = fgetc(stream);
-+ if (c == EOF) {
-+ return -1;
-+ }
-+ if (bufptr == NULL) {
-+ bufptr = malloc(128);
-+ if (bufptr == NULL) {
-+ return -1;
-+ }
-+ size = 128;
-+ }
-+ p = bufptr;
-+ while(c != EOF) {
-+ if ((p - bufptr) > (size - 1)) {
-+ size = size + 128;
-+ bufptr = realloc(bufptr, size);
-+ if (bufptr == NULL) {
-+ return -1;
-+ }
-+ }
-+ *p++ = c;
-+ if (c == '\n') {
-+ break;
-+ }
-+ c = fgetc(stream);
-+ }
-+
-+ *p++ = '\0';
-+ *lineptr = bufptr;
-+ *n = size;
-+
-+ return p - bufptr - 1;
-+}
-+
-+
-+
-+
-+
-+
-+
-+
-+
-+
- const char version_etc_copyright[] =
- /* Do *not* mark this string for translation. %s is a copyright
- symbol suitable for this locale, and %d is the copyright
-@@ -161,9 +223,10 @@
- free (output);
- }
- else
-- error (EXIT_FAILURE, 0, "%s: %s",
-+ exit(EXIT_FAILURE);
-+ /*error (EXIT_FAILURE, 0, "%s: %s",
- args_info.register_given ? "register" : "lookup",
-- idn2_strerror (rc));
-+ idn2_strerror (rc));*/
- }
-
- int
-@@ -222,7 +285,8 @@
- }
-
- if (ferror (stdin))
-- error (EXIT_FAILURE, errno, "%s", _("input error"));
-+ exit(EXIT_FAILURE);
-+ /*error (EXIT_FAILURE, errno, "%s", _("input error"));*/
-
- cmdline_parser_free (&args_info);
-