summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ded8e899ec8..c892593db7fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-libogg
pkgdesc = Ogg bitstream and framing library (mingw-w64)
pkgver = 1.3.5
- pkgrel = 1
+ pkgrel = 2
url = http://xiph.org
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 00fa457264b5..a3043a6acb7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mingw-w64-libogg
pkgver=1.3.5
-pkgrel=1
+pkgrel=2
pkgdesc="Ogg bitstream and framing library (mingw-w64)"
arch=(any)
url="http://xiph.org"
@@ -17,6 +17,11 @@ sha256sums=('c4d91be36fc8e54deae7575241e03f4211eb102afb3fc0775fbbc1b740016705')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
_pkgname="${pkgname#mingw-w64-}"
+prepare() {
+ cd ${_pkgname}-${pkgver}
+ curl -L https://github.com/xiph/ogg/pull/72.patch | patch -p1
+}
+
build() {
for _arch in ${_architectures}; do
${_arch}-cmake -S ${_pkgname}-${pkgver} -B build/${_arch}-static -G Ninja \
@@ -43,4 +48,4 @@ package() {
${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
done
-} \ No newline at end of file
+}