summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f03e5c326ddf..8d2be368f1a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,18 +2,17 @@ pkgbase = mingw-w64-libxau
pkgdesc = X11 authorisation library (mingw-w64)
pkgver = 1.0.8
pkgrel = 1
- url = http://xorg.freedesktop.org/
+ url = https://xorg.freedesktop.org
arch = any
license = custom
- makedepends = pkgconfig
+ makedepends = mingw-w64-pkg-config
makedepends = mingw-w64-configure
- makedepends = mingw-w64-gcc
depends = mingw-w64-crt
depends = mingw-w64-xproto
options = !strip
options = staticlibs
options = !buildflags
- source = http://xorg.freedesktop.org//releases/individual/lib/libXau-1.0.8.tar.bz2
+ source = libXau-1.0.8.tar.bz2::https://xorg.freedesktop.org/releases/individual/lib/libXau-1.0.8.tar.bz2
sha256sums = fdd477320aeb5cdd67272838722d6b7d544887dfe7de46e1e7cc0c27c2bea4f2
pkgname = mingw-w64-libxau
diff --git a/PKGBUILD b/PKGBUILD
index 505fa5ba042b..4c6bf6ffed44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,27 +6,25 @@
# Contributor: Alexander Baldeck <alexander@archlinux.org>
pkgname=mingw-w64-libxau
+_name=libXau
pkgver=1.0.8
pkgrel=1
pkgdesc="X11 authorisation library (mingw-w64)"
arch=('any')
-url="http://xorg.freedesktop.org/"
+url="https://xorg.freedesktop.org"
depends=('mingw-w64-crt' 'mingw-w64-xproto')
-makedepends=('pkgconfig' 'mingw-w64-configure' 'mingw-w64-gcc')
+makedepends=('mingw-w64-pkg-config' 'mingw-w64-configure')
license=('custom')
-source=(${url}/releases/individual/lib/libXau-${pkgver}.tar.bz2)
+source=("${_name}-${pkgver}.tar.bz2::${url}/releases/individual/lib/${_name}-${pkgver}.tar.bz2")
sha256sums=('fdd477320aeb5cdd67272838722d6b7d544887dfe7de46e1e7cc0c27c2bea4f2')
options=('!strip' 'staticlibs' '!buildflags')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd libXau-${pkgver}
+ cd "${srcdir}/${_name}-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- export CFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
- export CXXFLAGS=$CFLAGS
- export LDFLAGS="$LDFLAGS -lssp"
${_arch}-configure
make
popd
@@ -34,13 +32,14 @@ build() {
}
package() {
- cd libXau-${pkgver}
+ cd "${srcdir}/${_name}-${pkgver}"
for _arch in ${_architectures}; do
- cd "${srcdir}/libXau-${pkgver}/build-${_arch}"
+ pushd build-${_arch}
make DESTDIR="$pkgdir" install
rm -r "${pkgdir}/usr/${_arch}/share"
rm -f "${pkgdir}"/usr/${_arch}/bin/*.exe
${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
+ popd
done
}