summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e32479c3081..0afec2c38d0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-llvm
pkgdesc = Collection of modular and reusable compiler and toolchain technologies (mingw-w64)
pkgver = 16.0.6
- pkgrel = 2
+ pkgrel = 3
url = http://llvm.org/
arch = any
license = custom:Apache 2.0 with LLVM Exception
diff --git a/PKGBUILD b/PKGBUILD
index 2b4320b01557..c454a2fb5467 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=('mingw-w64-llvm')
pkgver=16.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="Collection of modular and reusable compiler and toolchain technologies (mingw-w64)"
arch=('any')
url="http://llvm.org/"
@@ -56,6 +56,7 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/llvm-$pkgver.src/build-${_arch}"
make DESTDIR="${pkgdir}" install
+ rm "${pkgdir}"/usr/${_arch}/bin/*.exe
${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
done