summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e4441dc71d8..d9cd21b2ec69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-physfs
pkgdesc = A library to provide abstract access to various archives (mingw-w64)
- pkgver = 3.0.2
+ pkgver = 3.2.0
pkgrel = 1
url = http://icculus.org/physfs/
arch = any
@@ -11,8 +11,7 @@ pkgbase = mingw-w64-physfs
options = !strip
options = !buildflags
options = !makeflags
- source = http://icculus.org/physfs/downloads/physfs-3.0.2.tar.bz2
- sha1sums = 6a15c458898d0570101d8f173201cde9ced78df7
+ source = https://github.com/icculus/physfs/archive/refs/tags/release-3.2.0.tar.gz
+ sha256sums = 1991500eaeb8d5325e3a8361847ff3bf8e03ec89252b7915e1f25b3f8ab5d560
pkgname = mingw-w64-physfs
-
diff --git a/PKGBUILD b/PKGBUILD
index dc69434f0bcb..8f62e8a6b9a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: edub4rt <edub4rt@gmail.com>
pkgname=mingw-w64-physfs
_basename=physfs
-pkgver=3.0.2
+pkgver=3.2.0
pkgrel=1
pkgdesc="A library to provide abstract access to various archives (mingw-w64)"
arch=('any')
@@ -10,13 +10,13 @@ license=('ZLIB')
makedepends=('mingw-w64-cmake')
depends=('mingw-w64-zlib')
options=(staticlibs '!strip' '!buildflags' '!makeflags')
-source=(http://icculus.org/physfs/downloads/${_basename}-${pkgver}.tar.bz2)
-sha1sums=('6a15c458898d0570101d8f173201cde9ced78df7')
+source=(https://github.com/icculus/physfs/archive/refs/tags/release-${pkgver}.tar.gz)
+sha256sums=('1991500eaeb8d5325e3a8361847ff3bf8e03ec89252b7915e1f25b3f8ab5d560')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd $_basename-$pkgver
+ cd $_basename-release-$pkgver
unset LDFLAGS
export CFLAGS="$CFLAGS -fno-strict-aliasing"
export CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"
@@ -34,7 +34,7 @@ build() {
}
package() {
- cd $_basename-$pkgver
+ cd $_basename-release-$pkgver
for _arch in ${_architectures}; do
cd build-${_arch}
make DESTDIR=${pkgdir} install