summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2f22cd643f7..049dd68cad28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = mingw-w64-protobuf
pkgdesc = Protocol Buffers - Google's data interchange format (mingw-w64)
- pkgver = 3.10.0
- pkgrel = 1
+ pkgver = 25.3
+ pkgrel = 2
url = https://developers.google.com/protocol-buffers/
arch = any
license = BSD
- makedepends = mingw-w64-configure
+ makedepends = mingw-w64-cmake
makedepends = protobuf
- makedepends = unzip
- depends = mingw-w64-crt
depends = mingw-w64-zlib
+ depends = mingw-w64-abseil-cpp
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/google/protobuf/archive/v3.10.0.tar.gz
- sha256sums = 758249b537abba2f21ebc2d02555bf080917f0f2f88f4cbe2903e0e28c4187ed
+ source = https://github.com/protocolbuffers/protobuf/releases/download/v25.3/protobuf-25.3.tar.gz
+ sha256sums = d19643d265b978383352b3143f04c0641eea75a75235c111cc01a1350173180e
pkgname = mingw-w64-protobuf
-
diff --git a/PKGBUILD b/PKGBUILD
index 19a1e46ca6dc..937863ba8c06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
-# Contributor: Benoit Favre <benoit.favre@gmail.com>
-
pkgname=('mingw-w64-protobuf')
_pkgname=protobuf
-pkgver=3.10.0
-pkgrel=1
+pkgver=25.3
+pkgrel=2
pkgdesc="Protocol Buffers - Google's data interchange format (mingw-w64)"
arch=('any')
url='https://developers.google.com/protocol-buffers/'
license=('BSD')
-depends=('mingw-w64-crt' 'mingw-w64-zlib')
-makedepends=('mingw-w64-configure' 'protobuf' 'unzip')
+depends=(mingw-w64-zlib mingw-w64-abseil-cpp)
+makedepends=(mingw-w64-cmake protobuf)
options=(!strip !buildflags staticlibs)
-source=("https://github.com/google/protobuf/archive/v${pkgver}.tar.gz")
-sha256sums=('758249b537abba2f21ebc2d02555bf080917f0f2f88f4cbe2903e0e28c4187ed')
+source=("https://github.com/protocolbuffers/${_pkgname}/releases/download/v$pkgver/${_pkgname}-$pkgver.tar.gz")
+sha256sums=('d19643d265b978383352b3143f04c0641eea75a75235c111cc01a1350173180e')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
- ./autogen.sh
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure --with-protoc=/usr/bin/protoc ..
+ ${_arch}-cmake -Dprotobuf_BUILD_TESTS=OFF -Dprotobuf_ABSL_PROVIDER=package ..
make
popd
done