summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD2
-rw-r--r--wine-python.sh8
2 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1ee52883b65..3ffb55ac2823 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,7 +30,7 @@ build() {
target=".amd64"
fi
mkdir -p "build-${_arch}" && pushd "build-${_arch}"
- msiexec /i "${srcdir}"/python-${pkgver}${target}.msi /qb TARGETDIR=$PWD
+ ${_arch}-msiexec /i "${srcdir}"/python-${pkgver}${target}.msi /qb TARGETDIR=$PWD
gendef python${_pybasever}.dll
${_arch}-dlltool --dllname python${_pybasever}.dll --def python${_pybasever}.def --output-lib libs/libpython${_pybasever}.dll.a
sed "s|@TRIPLE@|${_arch}|g;s|@PYVER@|${_pybasever}|g" "${srcdir}"/wine-python.sh > ${_arch}-python${_pybasever}-bin
diff --git a/wine-python.sh b/wine-python.sh
index 19bb168e7b95..83601211eb50 100644
--- a/wine-python.sh
+++ b/wine-python.sh
@@ -3,6 +3,12 @@
set -e
export PYTHONHOME=/usr/@TRIPLE@
-export PYTHONPATH=/usr/@TRIPLE@/lib/python@PYVER@
+
+if test -z "${PYTHONPATH}"
+then
+ export PYTHONPATH=/usr/@TRIPLE@/lib/python@PYVER@
+else
+ export PYTHONPATH="${PYTHONPATH};/usr/@TRIPLE@/lib/python@PYVER@"
+fi
@TRIPLE@-wine /usr/@TRIPLE@/bin/python@PYVER@.exe "$@"