summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD15
-rw-r--r--wine-python.sh4
3 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6689c3dacdda..91ae794115a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-python36-bin
pkgdesc = Next generation of the python high-level scripting language (native MSVC version) (mingw-w64)
- pkgver = 3.6.5
- pkgrel = 3
+ pkgver = 3.6.8
+ pkgrel = 2
url = http://www.python.org/
arch = any
license = PSF
@@ -9,21 +9,20 @@ pkgbase = mingw-w64-python36-bin
makedepends = mingw-w64-binutils
depends = mingw-w64-crt
optdepends = mingw-w64-wine: runtime support
- noextract = python-3.6.5-embed-win32.zip
- noextract = python-3.6.5-embed-amd64.zip
+ noextract = python-3.6.8-embed-win32.zip
+ noextract = python-3.6.8-embed-amd64.zip
options = staticlibs
options = !buildflags
options = !strip
- source = https://www.python.org/ftp/python/3.6.5/python-3.6.5-embed-win32.zip
- source = https://www.python.org/ftp/python/3.6.5/python-3.6.5-embed-amd64.zip
- source = https://www.python.org/ftp/python/3.6.5/Python-3.6.5.tgz
+ source = https://www.python.org/ftp/python/3.6.8/python-3.6.8-embed-win32.zip
+ source = https://www.python.org/ftp/python/3.6.8/python-3.6.8-embed-amd64.zip
+ source = https://www.python.org/ftp/python/3.6.8/Python-3.6.8.tgz
source = wine-python.sh
source = bpo-11566.patch
- sha256sums = f654c055817b5a2c5b050d744833d95d621aeaa507b5c28b4840712821a70891
- sha256sums = dfb476fabd20f617c8a5be58ca3e55844c8310710c6ff0dd25486d1d03c95a28
- sha256sums = 53a3e17d77cd15c5230192b6a8c1e031c07cd9f34a2f089a731c6f6bd343d5c6
- sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = b4c65c63344c29c716f58c80fb91999f15af0992a142d5ed33cd12d22aa941e0
+ sha256sums = efadf25a090c8438b3cbe27574fb36bd40c80e20a03939188a1d5051685495dd
+ sha256sums = 7f5b1f08b3b0a595387ef6c64c85b1b13b38abef0dd871835ee923262e4f32f0
+ sha256sums = a76a4715e87d3ed4aca6babc8715de8de94513dae4c683c1681551c43698b5ae
+ sha256sums = 5a98c6b2111370a7f9c619be97572d01e2587cc3fe94af154003ba1a3f644891
pkgname = mingw-w64-python36-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 77340f6131ee..68e692a35bb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-python36-bin
-pkgver=3.6.5
+pkgver=3.6.8
_pybasever=36
-pkgrel=3
+pkgrel=2
pkgdesc="Next generation of the python high-level scripting language (native MSVC version) (mingw-w64)"
arch=('any')
license=('PSF')
@@ -16,10 +16,11 @@ source=("https://www.python.org/ftp/python/${pkgver}/python-${pkgver}-embed-win3
wine-python.sh bpo-11566.patch)
noextract=("python-${pkgver}-embed-win32.zip"
"python-${pkgver}-embed-amd64.zip")
-sha256sums=('f654c055817b5a2c5b050d744833d95d621aeaa507b5c28b4840712821a70891'
- 'dfb476fabd20f617c8a5be58ca3e55844c8310710c6ff0dd25486d1d03c95a28'
- '53a3e17d77cd15c5230192b6a8c1e031c07cd9f34a2f089a731c6f6bd343d5c6'
- SKIP SKIP)
+sha256sums=('b4c65c63344c29c716f58c80fb91999f15af0992a142d5ed33cd12d22aa941e0'
+ 'efadf25a090c8438b3cbe27574fb36bd40c80e20a03939188a1d5051685495dd'
+ '7f5b1f08b3b0a595387ef6c64c85b1b13b38abef0dd871835ee923262e4f32f0'
+ 'a76a4715e87d3ed4aca6babc8715de8de94513dae4c683c1681551c43698b5ae'
+ '5a98c6b2111370a7f9c619be97572d01e2587cc3fe94af154003ba1a3f644891')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -27,6 +28,8 @@ prepare () {
cd "${srcdir}/Python-${pkgver}"
# https://bugs.python.org/issue11566
patch -p1 -i "${srcdir}"/bpo-11566.patch
+ # https://bugs.python.org/issue36020
+ sed -i 's|#if defined(MS_WIN32) \&\& !defined(HAVE_SNPRINTF)|#if defined(_MSC_VER) \&\& !defined(HAVE_SNPRINTF)|g' Include/pyerrors.h
}
build() {
diff --git a/wine-python.sh b/wine-python.sh
index 83601211eb50..c41caeeee959 100644
--- a/wine-python.sh
+++ b/wine-python.sh
@@ -11,4 +11,6 @@ else
export PYTHONPATH="${PYTHONPATH};/usr/@TRIPLE@/lib/python@PYVER@"
fi
-@TRIPLE@-wine /usr/@TRIPLE@/bin/python@PYVER@.exe "$@"
+# https://bugs.winehq.org/show_bug.cgi?id=51813
+set -o pipefail
+@TRIPLE@-wine /usr/@TRIPLE@/bin/python@PYVER@.exe "$@" | tee