summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
-rw-r--r--wine-python.sh8
3 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7693226132a..1d47b9d94892 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = mingw-w64-python36-bin
license = PSF
makedepends = mingw-w64-tools
makedepends = mingw-w64-binutils
+ makedepends = python2-numpy
depends = mingw-w64-crt
optdepends = mingw-w64-wine: runtime support
noextract = python-3.6.5-embed-win32.zip
diff --git a/PKGBUILD b/PKGBUILD
index 75778cefab63..538228a0da71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ license=('PSF')
url="http://www.python.org/"
depends=('mingw-w64-crt')
optdepends=('mingw-w64-wine: runtime support')
-makedepends=('mingw-w64-tools' 'mingw-w64-binutils')
+makedepends=('mingw-w64-tools' 'mingw-w64-binutils' 'python2-numpy')
options=('staticlibs' '!buildflags' '!strip')
source=("https://www.python.org/ftp/python/${pkgver}/python-${pkgver}-embed-win32.zip"
"https://www.python.org/ftp/python/${pkgver}/python-${pkgver}-embed-amd64.zip"
diff --git a/wine-python.sh b/wine-python.sh
index 19bb168e7b95..83601211eb50 100644
--- a/wine-python.sh
+++ b/wine-python.sh
@@ -3,6 +3,12 @@
set -e
export PYTHONHOME=/usr/@TRIPLE@
-export PYTHONPATH=/usr/@TRIPLE@/lib/python@PYVER@
+
+if test -z "${PYTHONPATH}"
+then
+ export PYTHONPATH=/usr/@TRIPLE@/lib/python@PYVER@
+else
+ export PYTHONPATH="${PYTHONPATH};/usr/@TRIPLE@/lib/python@PYVER@"
+fi
@TRIPLE@-wine /usr/@TRIPLE@/bin/python@PYVER@.exe "$@"