aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e89a985f360f..5dca4b46b871 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Feb 3 22:50:54 UTC 2016
+# Tue Mar 8 23:25:30 UTC 2016
pkgbase = mingw-w64-qt5-base
pkgdesc = A cross-platform application and UI framework (mingw-w64)
pkgver = 5.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 219067fa243e..c8809529613a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=mingw-w64-qt5-base
pkgver=5.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
arch=(i686 x86_64)
url="https://www.qt.io/"
@@ -252,14 +252,22 @@ build() {
# fix include directory of dbus
qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I dbus-1 --cflags)"
- isOpenGL && qt_configure_args+=' -opengl desktop'
- isStatic && qt_configure_args+=' -opengl no'
+ if isStatic; then
+ qt_configure_args+=' -opengl no'
+ elif isOpenGL; then
+ qt_configure_args+=' -opengl desktop'
+ else
+ # GL_GLEXT_PROTOTYPES must be defined to enable declarations GLES functions
+ qt_configure_args+=' -DGL_GLEXT_PROTOTYPES'
+ fi
+ # TODO: allow dynamic OpenGL configuration
unset PKG_CONFIG_PATH
if ! isStatic; then
export QT_LFLAGS_MYSQL="-L/usr/${_arch}/lib -lmysql"
fi
+
# Qt doesn't detect mysql correctly, so use this:
export QT_CFLAGS_MYSQL="-I/usr/${_arch}/include/mariadb"
#export QT_LFLAGS_MYSQL_R="-lmariadbclient -lws2_32 -lpthread -lz -lm -lssl -lcrypto"