aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--qt5-allow-usage-of-static-qt-with-cmake.patch35
3 files changed, 36 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59c3f879e0d3..9b5f21063dc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Sep 12 18:06:40 UTC 2016
+# Sun Sep 18 17:29:02 UTC 2016
pkgbase = mingw-w64-qt5-base-angle
pkgdesc = A cross-platform application and UI framework (mingw-w64)
pkgver = 5.7.0
- pkgrel = 6
+ pkgrel = 8
url = https://www.qt.io/
arch = i686
arch = x86_64
@@ -84,7 +84,7 @@ pkgbase = mingw-w64-qt5-base-angle
md5sums = 83139869355c2d46921adb25e47cf0fa
md5sums = b9565219e9252a17fc1b8fb9ee30662c
md5sums = 20de722808e8a3fb684b0212bef8de46
- md5sums = 1dc792faa7761d8d7d2f17170da04d6b
+ md5sums = a60bd6bb231acfe9132f391a26b37e71
md5sums = 41ec67d9e5e70e0d6d93b42aebd0e12a
md5sums = 61c0f9d0095c5a6dec8d14e9ec35a608
md5sums = 16a7d505b503bb1087fc00fad819f64b
diff --git a/PKGBUILD b/PKGBUILD
index 9d8bb5f90659..93b3778d524b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -70,7 +70,7 @@ isNoOpenGL() {
pkgname=mingw-w64-qt5-base-angle
pkgver=5.7.0
-pkgrel=6
+pkgrel=8
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
# The static variant doesn't contain any executables which need to be executed on the build machine
isStatic && arch=('any') || arch=('i686' 'x86_64')
@@ -129,7 +129,7 @@ md5sums=('184f9460b40752d71b15b827260580c2'
'83139869355c2d46921adb25e47cf0fa'
'b9565219e9252a17fc1b8fb9ee30662c'
'20de722808e8a3fb684b0212bef8de46'
- '1dc792faa7761d8d7d2f17170da04d6b'
+ 'a60bd6bb231acfe9132f391a26b37e71'
'41ec67d9e5e70e0d6d93b42aebd0e12a'
'61c0f9d0095c5a6dec8d14e9ec35a608'
'16a7d505b503bb1087fc00fad819f64b')
@@ -287,11 +287,18 @@ build() {
for _arch in ${_architectures}; do
# Phonon is disabled for now because we lack the directx headers
+ # FIXME: check whether this is still the case
+
# The odd paths for the -hostbindir argument are on purpose
# The qtchooser tool assumes that the tools 'qmake', 'moc' and others
# are all available in the same folder with these exact file names
# To prevent conflicts with the mingw-w64-qt4 package we have
# to put these tools in a dedicated folder
+
+ # The last device option allows using ccache though the use of
+ # pre-compile header
+ # (sloppiness must be set to pch_defines,time_macros in ccache config)
+
local qt_configure_args="\
-xplatform win32-g++ \
-optimized-qmake \
@@ -331,7 +338,8 @@ build() {
-plugindir /usr/${_arch}/lib/qt/plugins \
-sysconfdir /usr/${_arch}/etc \
-translationdir /usr/${_arch}/share/qt/translations \
- -device-option CROSS_COMPILE=${_arch}-"
+ -device-option CROSS_COMPILE=${_arch}- \
+ -device-option CROSS_COMPILE_CFLAGS=-fpch-preprocess"
# Fix include directory of freetype2 and dbus
qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I freetype2 dbus-1)"
diff --git a/qt5-allow-usage-of-static-qt-with-cmake.patch b/qt5-allow-usage-of-static-qt-with-cmake.patch
index 844db1e7ce41..dd81611626d5 100644
--- a/qt5-allow-usage-of-static-qt-with-cmake.patch
+++ b/qt5-allow-usage-of-static-qt-with-cmake.patch
@@ -1,5 +1,5 @@
--- mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in.orig 2016-08-14 20:44:32.515151700 +0200
-+++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-18 23:22:00.447257800 +0200
++++ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2016-08-19 16:04:30.074766100 +0200
@@ -59,19 +59,30 @@
set_property(TARGET Qt5::$${CMAKE_MODULE_NAME} APPEND PROPERTY IMPORTED_CONFIGURATIONS ${Configuration})
@@ -291,29 +291,38 @@
!!IF !isEmpty(CMAKE_MODULE_EXTRAS)
include(\"${CMAKE_CURRENT_LIST_DIR}/Qt5$${CMAKE_MODULE_NAME}ConfigExtras.cmake\")
---- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-06-10 08:48:56.000000000 +0200
-+++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-08-18 23:22:41.994211700 +0200
-@@ -2,10 +2,18 @@
- add_library(Qt5::$$CMAKE_PLUGIN_NAME MODULE IMPORTED)
+--- mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in.orig 2016-08-19 16:04:30.075761600 +0200
++++ mkspecs/features/data/cmake/Qt5PluginTarget.cmake.in 2016-09-17 16:00:01.818295000 +0200
+@@ -1,11 +1,22 @@
+-
+-add_library(Qt5::$$CMAKE_PLUGIN_NAME MODULE IMPORTED)
++# Some Qt modules also load plugin target in extra config, so check
++# whether the target already exists
++if(NOT TARGET Qt5::$$CMAKE_PLUGIN_NAME)
++ add_library(Qt5::$$CMAKE_PLUGIN_NAME MODULE IMPORTED)
!!IF !isEmpty(CMAKE_RELEASE_TYPE)
+-_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!IF !isEmpty(CMAKE_STATIC_TYPE)
-+_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE_STATIC}\")
++ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE_STATIC}\")
+!!ELSE
- _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
- !!ENDIF
++ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME RELEASE \"$${CMAKE_PLUGIN_LOCATION_RELEASE}\")
+!!ENDIF
+ !!ENDIF
!!IF !isEmpty(CMAKE_DEBUG_TYPE)
+-_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME DEBUG \"$${CMAKE_PLUGIN_LOCATION_DEBUG}\")
+!!IF !isEmpty(CMAKE_STATIC_TYPE)
-+_populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME DEBUG \"$${CMAKE_PLUGIN_LOCATION_DEBUG_STATIC}\")
++ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME DEBUG \"$${CMAKE_PLUGIN_LOCATION_DEBUG_STATIC}\")
+!!ELSE
- _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME DEBUG \"$${CMAKE_PLUGIN_LOCATION_DEBUG}\")
- !!ENDIF
++ _populate_$${CMAKE_MODULE_NAME}_plugin_properties($$CMAKE_PLUGIN_NAME DEBUG \"$${CMAKE_PLUGIN_LOCATION_DEBUG}\")
+!!ENDIF
+ !!ENDIF
- list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
+-list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
++ list(APPEND Qt5$${CMAKE_MODULE_NAME}_PLUGINS Qt5::$$CMAKE_PLUGIN_NAME)
++endif()
--- mkspecs/features/create_cmake.prf.orig 2016-08-14 20:44:32.513342200 +0200
-+++ mkspecs/features/create_cmake.prf 2016-08-18 22:47:39.606635000 +0200
++++ mkspecs/features/create_cmake.prf 2016-08-19 16:04:30.073546600 +0200
@@ -135,17 +135,19 @@
CMAKE_PLUGIN_NAME = $$PLUGIN_CLASS_NAME