summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--PKGBUILD.bak54
3 files changed, 8 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c198e5b68774..bd27b35db32e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 8 19:41:08 UTC 2016
+# Sat Dec 24 12:06:50 UTC 2016
pkgbase = mingw-w64-qt5-connectivity
pkgdesc = Provides access to Bluetooth hardware (mingw-w64)
- pkgver = 5.7.0
- pkgrel = 3
+ pkgver = 5.7.1
+ pkgrel = 1
url = https://www.qt.io/
arch = any
license = GPL3
@@ -18,8 +18,8 @@ pkgbase = mingw-w64-qt5-connectivity
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.7/5.7.0/submodules/qtconnectivity-opensource-src-5.7.0.tar.xz
- md5sums = 56229b15e677ee98d56446519723fb3b
+ source = https://download.qt.io/official_releases/qt/5.7/5.7.1/submodules/qtconnectivity-opensource-src-5.7.1.tar.xz
+ md5sums = 032e5635bb2f3fbaecbe112d804d3f4b
pkgname = mingw-w64-qt5-connectivity
diff --git a/PKGBUILD b/PKGBUILD
index 248eb6d98b86..81502720fc7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
_qt_module=qtconnectivity
pkgname="mingw-w64-qt5-connectivity"
-pkgver=5.7.0
-pkgrel=3
+pkgver=5.7.1
+pkgrel=1
arch=('any')
pkgdesc="Provides access to Bluetooth hardware (mingw-w64)"
depends=('mingw-w64-qt5-base')
@@ -19,7 +19,7 @@ license=('GPL3' 'LGPL3' 'FDL' 'custom')
url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-md5sums=('56229b15e677ee98d56446519723fb3b')
+md5sums=('032e5635bb2f3fbaecbe112d804d3f4b')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
diff --git a/PKGBUILD.bak b/PKGBUILD.bak
deleted file mode 100644
index 1d96b7749314..000000000000
--- a/PKGBUILD.bak
+++ /dev/null
@@ -1,54 +0,0 @@
-# Maintainer: Martchus <martchus@gmx.net>
-# Contributor: ant32 <antreimer@gmail.com>
-
-_qt_module=qt3d
-pkgname="mingw-w64-qt5-3d"
-pkgver=5.5.1
-pkgrel=1
-arch=('any')
-pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
-depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative' 'mingw-w64-qt5-quick1')
-makedepends=('mingw-w64-gcc')
-options=('!strip' '!buildflags' 'staticlibs')
-license=('GPL3' 'LGPL')
-url="https://www.qt.io/"
-_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-md5sums=('872dfbe166154c2e0e89317ab23d2cd6')
-
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-
-build() {
- cd "${srcdir}/${_pkgfqn}"
-
- for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
-
- ${_arch}-qmake-qt5 ../${_qt_module}.pro
- make
-
- popd
- done
-}
-
-package() {
- cd "${srcdir}/${_pkgfqn}"
-
- for _arch in ${_architectures}; do
- pushd build-${_arch}
-
- make INSTALL_ROOT="${pkgdir}" install
-
- # The .dll's are installed in both bindir and libdir
- # One copy of the .dll's is sufficient
- rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
-
- ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
- ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
-
- popd
- done
-
- # .prl files aren't interesting for us
- find "${pkgdir}" -name "*.prl" -delete
-}