summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Ensure-static-plugins-are-exported.patch4
-rw-r--r--0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch4
-rwxr-xr-xPKGBUILD20
-rw-r--r--PKGBUILD.sh.ep6
-rw-r--r--qtdeclarative-sha256.txt2
6 files changed, 19 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f64e51c8711..c09524f20494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-declarative
pkgdesc = Classes for QML and JavaScript languages (mingw-w64)
- pkgver = 5.15.0
+ pkgver = 5.15.1
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -14,18 +14,16 @@ pkgbase = mingw-w64-qt5-declarative
makedepends = mingw-w64-vulkan-headers
makedepends = mingw-w64-pkg-config
makedepends = python
- makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-base
- optdepends = mingw-w64-qt5-base-static: use of static libraries
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.0/submodules/qtdeclarative-everywhere-src-5.15.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qtdeclarative-everywhere-src-5.15.1.tar.xz
source = 0001-Ensure-static-plugins-are-exported.patch
source = 0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
- sha256sums = 9c3c93fb7d340b2f7d738d12408c047318c78973cb45bfc5ff6b3a57e1fef699
- sha256sums = 4af477df8c06dfd9fd5a8a34ec5b79e175e87187a040d7081bd5eaa809c7d81d
- sha256sums = f3463ab91e8b6b12b4dd210ae012203ef83f90a2ce59a2f324daf0a98ed3f0b5
+ sha256sums = 7e30f0ccba61f9d71720b91d7f7523c23677f23cd96065cb71df1b0df329d768
+ sha256sums = accdeab4cb49857442f680a6013a648108ec4f00078e492475794aa6cc98257e
+ sha256sums = 7ff5093753aa819c6039de796e6ebffa235b51f57403e827b31a90e8c2ffbf60
pkgname = mingw-w64-qt5-declarative
diff --git a/0001-Ensure-static-plugins-are-exported.patch b/0001-Ensure-static-plugins-are-exported.patch
index 364d4df0675e..5929d8b9aafc 100644
--- a/0001-Ensure-static-plugins-are-exported.patch
+++ b/0001-Ensure-static-plugins-are-exported.patch
@@ -1,4 +1,4 @@
-From 0ac71a10df126230e54db3b65b605678d00bb1ac Mon Sep 17 00:00:00 2001
+From 20cd4da89edeec706cfc4472b0e9a2df58844a7c Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 23 Oct 2016 01:18:13 +0200
Subject: [PATCH 1/2] Ensure static plugins are exported
@@ -19,5 +19,5 @@ index 4242143bca..bccb7b3146 100644
foreach(_other_plugin ${_qt5qml_other_plugins})
include(${_other_plugin} OPTIONAL)
--
-2.26.2
+2.28.0
diff --git a/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch b/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
index ca23bd52300b..2e58a0d82787 100644
--- a/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
+++ b/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
@@ -1,4 +1,4 @@
-From 1aca21342b43a16c9c1cc6af0514e9dc2b28917a Mon Sep 17 00:00:00 2001
+From c7d18dc02b67c3a7db5f2d32759829df27bc9f7d Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 4 Feb 2017 01:59:59 +0100
Subject: [PATCH 2/2] Prevent exporting QML parser symbols on static build
@@ -33,5 +33,5 @@ index bf8155c6ec..2bfa230bcc 100644
# define QML_PARSER_EXPORT
# elif defined(QT_BUILD_QML_LIB)
--
-2.26.2
+2.28.0
diff --git a/PKGBUILD b/PKGBUILD
index fd835d6733fd..6cca876249eb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,15 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
# Do not edit it manually! See README.md in the repository's root directory
# for more information.
# All patches are managed at https://github.com/Martchus/qtdeclarative
-# Includes dynamic and static versions; if only one version is requried, just
-# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
-
_qt_module=qtdeclarative
pkgname=mingw-w64-qt5-declarative
-pkgver=5.15.0
+pkgver=5.15.1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
@@ -31,18 +28,13 @@ _pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Ensure-static-plugins-are-exported.patch'
'0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch')
-sha256sums=('9c3c93fb7d340b2f7d738d12408c047318c78973cb45bfc5ff6b3a57e1fef699'
- '4af477df8c06dfd9fd5a8a34ec5b79e175e87187a040d7081bd5eaa809c7d81d'
- 'f3463ab91e8b6b12b4dd210ae012203ef83f90a2ce59a2f324daf0a98ed3f0b5')
+sha256sums=('7e30f0ccba61f9d71720b91d7f7523c23677f23cd96065cb71df1b0df329d768'
+ 'accdeab4cb49857442f680a6013a648108ec4f00078e492475794aa6cc98257e'
+ '7ff5093753aa819c6039de796e6ebffa235b51f57403e827b31a90e8c2ffbf60')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-[[ $NO_STATIC_LIBS ]] || \
- makedepends+=('mingw-w64-qt5-base-static') \
- optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
-[[ $NO_SHARED_LIBS ]] || \
- _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
prepare() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 23c45dfd6aa6..74230bc434cd 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -6,11 +6,11 @@
# Contributor: ohmyarch
% end
\
-pkgver=5.15.0
+pkgver=5.15.1
pkgrel=1
-arch=('i686' 'x86_64')
+arch=(<%== include 'fragments/mingw-w64-qt5-non_any_archs' %>)
pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
-depends=('mingw-w64-qt5-base')
+depends=(<%== qt5deps qw(base) %>)
makedepends=('mingw-w64-gcc' 'mingw-w64-vulkan-headers' 'mingw-w64-pkg-config' 'python')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
\
diff --git a/qtdeclarative-sha256.txt b/qtdeclarative-sha256.txt
index 07703522492c..57759ad9eb4b 100644
--- a/qtdeclarative-sha256.txt
+++ b/qtdeclarative-sha256.txt
@@ -1 +1 @@
-9c3c93fb7d340b2f7d738d12408c047318c78973cb45bfc5ff6b3a57e1fef699
+7e30f0ccba61f9d71720b91d7f7523c23677f23cd96065cb71df1b0df329d768