summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Ensure-static-plugins-are-exported.patch17
-rw-r--r--0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch4
-rwxr-xr-xPKGBUILD8
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qtdeclarative-sha256.txt2
6 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f26ca817e72..1f64e51c8711 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-declarative
pkgdesc = Classes for QML and JavaScript languages (mingw-w64)
- pkgver = 5.14.2
+ pkgver = 5.15.0
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -20,12 +20,12 @@ pkgbase = mingw-w64-qt5-declarative
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.2/submodules/qtdeclarative-everywhere-src-5.14.2.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.15/5.15.0/submodules/qtdeclarative-everywhere-src-5.15.0.tar.xz
source = 0001-Ensure-static-plugins-are-exported.patch
source = 0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
- sha256sums = a3c4617adc9760347c93d2eb6c25d22f620cd22f44afa0494eb499a805831650
- sha256sums = ee3ce91b18ff2beb650d56fd84bbeb1b22baee784aa56bfa81db64397a81b7ae
- sha256sums = 732f560982d87c890f2da859bc24116b9f3061bc0ec227ab201e449d34aedda7
+ sha256sums = 9c3c93fb7d340b2f7d738d12408c047318c78973cb45bfc5ff6b3a57e1fef699
+ sha256sums = 4af477df8c06dfd9fd5a8a34ec5b79e175e87187a040d7081bd5eaa809c7d81d
+ sha256sums = f3463ab91e8b6b12b4dd210ae012203ef83f90a2ce59a2f324daf0a98ed3f0b5
pkgname = mingw-w64-qt5-declarative
diff --git a/0001-Ensure-static-plugins-are-exported.patch b/0001-Ensure-static-plugins-are-exported.patch
index 308c2da65315..364d4df0675e 100644
--- a/0001-Ensure-static-plugins-are-exported.patch
+++ b/0001-Ensure-static-plugins-are-exported.patch
@@ -1,4 +1,4 @@
-From 725198b92bd02b7933c941ad4d660a0e6db1257b Mon Sep 17 00:00:00 2001
+From 0ac71a10df126230e54db3b65b605678d00bb1ac Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 23 Oct 2016 01:18:13 +0200
Subject: [PATCH 1/2] Ensure static plugins are exported
@@ -8,15 +8,16 @@ Subject: [PATCH 1/2] Ensure static plugins are exported
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/qml/Qt5QmlConfigExtras.cmake.in b/src/qml/Qt5QmlConfigExtras.cmake.in
-index 9ddb9885cd..9775d85e08 100644
+index 4242143bca..bccb7b3146 100644
--- a/src/qml/Qt5QmlConfigExtras.cmake.in
+++ b/src/qml/Qt5QmlConfigExtras.cmake.in
-@@ -1,4 +1,4 @@
--file(GLOB _qt5qml_other_plugins "${CMAKE_CURRENT_LIST_DIR}/Qt5Qml_*Factory.cmake")
-+file(GLOB _qt5qml_other_plugins "${CMAKE_CURRENT_LIST_DIR}/*Qt5Qml_*Factory.cmake")
+@@ -1,5 +1,5 @@
+ if(QT5_STRICT_PLUGIN_GLOB OR Qt5Qml_STRICT_PLUGIN_GLOB)
+- file(GLOB _qt5qml_other_plugins "${CMAKE_CURRENT_LIST_DIR}/Qt5Qml_*Factory.cmake")
++ file(GLOB _qt5qml_other_plugins "${CMAKE_CURRENT_LIST_DIR}/*Qt5Qml_*Factory.cmake")
- foreach(_other_plugin ${_qt5qml_other_plugins})
- include(${_other_plugin} OPTIONAL)
+ foreach(_other_plugin ${_qt5qml_other_plugins})
+ include(${_other_plugin} OPTIONAL)
--
-2.26.0
+2.26.2
diff --git a/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch b/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
index 86df31e0943c..ca23bd52300b 100644
--- a/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
+++ b/0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch
@@ -1,4 +1,4 @@
-From b051932d087b108a65d94f04d78dff41676b4ff9 Mon Sep 17 00:00:00 2001
+From 1aca21342b43a16c9c1cc6af0514e9dc2b28917a Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 4 Feb 2017 01:59:59 +0100
Subject: [PATCH 2/2] Prevent exporting QML parser symbols on static build
@@ -33,5 +33,5 @@ index bf8155c6ec..2bfa230bcc 100644
# define QML_PARSER_EXPORT
# elif defined(QT_BUILD_QML_LIB)
--
-2.26.0
+2.26.2
diff --git a/PKGBUILD b/PKGBUILD
index 128f2c7d9513..fd835d6733fd 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@
_qt_module=qtdeclarative
pkgname=mingw-w64-qt5-declarative
-pkgver=5.14.2
+pkgver=5.15.0
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
@@ -31,9 +31,9 @@ _pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Ensure-static-plugins-are-exported.patch'
'0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch')
-sha256sums=('a3c4617adc9760347c93d2eb6c25d22f620cd22f44afa0494eb499a805831650'
- 'ee3ce91b18ff2beb650d56fd84bbeb1b22baee784aa56bfa81db64397a81b7ae'
- '732f560982d87c890f2da859bc24116b9f3061bc0ec227ab201e449d34aedda7')
+sha256sums=('9c3c93fb7d340b2f7d738d12408c047318c78973cb45bfc5ff6b3a57e1fef699'
+ '4af477df8c06dfd9fd5a8a34ec5b79e175e87187a040d7081bd5eaa809c7d81d'
+ 'f3463ab91e8b6b12b4dd210ae012203ef83f90a2ce59a2f324daf0a98ed3f0b5')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index aad6b3fd4413..23c45dfd6aa6 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -6,7 +6,7 @@
# Contributor: ohmyarch
% end
\
-pkgver=5.14.2
+pkgver=5.15.0
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
diff --git a/qtdeclarative-sha256.txt b/qtdeclarative-sha256.txt
index 2ed54c12afa7..07703522492c 100644
--- a/qtdeclarative-sha256.txt
+++ b/qtdeclarative-sha256.txt
@@ -1 +1 @@
-a3c4617adc9760347c93d2eb6c25d22f620cd22f44afa0494eb499a805831650
+9c3c93fb7d340b2f7d738d12408c047318c78973cb45bfc5ff6b3a57e1fef699