summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2577be86f0e2..c959339e6b9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-networkauth
pkgdesc = Network authentication module (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -10,12 +10,12 @@ pkgbase = mingw-w64-qt5-networkauth
license = FDL
license = custom
makedepends = mingw-w64-gcc
+ makedepends = git
depends = mingw-w64-qt5-base
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtnetworkauth-everywhere-src-5.15.2.tar.xz
- sha256sums = fcc2ec42faa68561efa8f00cd72e662fbc06563ebc6de1dc42d96bb2997acd85
+ source = git+https://invent.kde.org/qt/qt/qtnetworkauth#commit=958db00a2064f77b354b573102ca2c2b2e07529c
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-networkauth
-
diff --git a/PKGBUILD b/PKGBUILD
index 4aa28c48df59..b9d77ee7c96b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_qt_module=qtnetworkauth
pkgname=mingw-w64-qt5-networkauth
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Network authentication module (mingw-w64)"
@@ -18,17 +18,30 @@ depends=('mingw-w64-qt5-base')
optdepends=()
makedepends=('mingw-w64-gcc')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=958db00a2064f77b354b573102ca2c2b2e07529c
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('fcc2ec42faa68561efa8f00cd72e662fbc06563ebc6de1dc42d96bb2997acd85')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 8024842a7553..31ef962cc7a0 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -4,7 +4,7 @@
# Contributor: ant32 <antreimer@gmail.com>
% end
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Network authentication module (mingw-w64)"