summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD45
-rw-r--r--PKGBUILD.sh.ep14
-rw-r--r--qtsensors-sha256.txt1
4 files changed, 47 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 559c95df5986..a53e9011a9dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-sensors
pkgdesc = Provides access to sensor hardware and motion gesture recognition (mingw-w64)
- pkgver = 5.13.0
+ pkgver = 5.15.13
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,15 +11,13 @@ pkgbase = mingw-w64-qt5-sensors
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
- makedepends = mingw-w64-qt5-base-static
+ makedepends = git
depends = mingw-w64-qt5-base
depends = mingw-w64-qt5-declarative
- optdepends = mingw-w64-qt5-base-static: use of static libraries
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.13/5.13.0/submodules/qtsensors-everywhere-src-5.13.0.tar.xz
- sha256sums = 1fae52836c786a9fd50e9e1d590384b9aea479f4569e33fc2d69536bbe2cde48
+ source = git+https://invent.kde.org/qt/qt/qtsensors#commit=7f8b55744f87155a4979dd8ba405bd7feec03042
+ sha256sums = 38eb6df8dc8c7346bec8a6e758c2798ff4a3547056c03189c9a6d4581fc9cd05
pkgname = mingw-w64-qt5-sensors
-
diff --git a/PKGBUILD b/PKGBUILD
index e4fe7b141492..515bd1b3ff0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,41 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-# Includes dynamic and static versions; if only one version is requried, just
-# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
_qt_module=qtsensors
pkgname=mingw-w64-qt5-sensors
-pkgver=5.13.0
+pkgver=5.15.13
pkgrel=1
arch=('any')
pkgdesc="Provides access to sensor hardware and motion gesture recognition (mingw-w64)"
depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
-options=('!strip' '!buildflags' 'staticlibs')
-groups=('mingw-w64-qt5')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=7f8b55744f87155a4979dd8ba405bd7feec03042
+_basever=${pkgver%%+*}
+makedepends+=('git')
+options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('1fae52836c786a9fd50e9e1d590384b9aea479f4569e33fc2d69536bbe2cde48')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('38eb6df8dc8c7346bec8a6e758c2798ff4a3547056c03189c9a6d4581fc9cd05')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-[[ $NO_STATIC_LIBS ]] || \
- makedepends+=('mingw-w64-qt5-base-static') \
- optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
-[[ $NO_SHARED_LIBS ]] || \
- _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+
+_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
build() {
cd "${srcdir}/${_pkgfqn}"
@@ -40,8 +48,8 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
- make
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
+ make -j$(nproc)
popd
done
done
@@ -54,7 +62,7 @@ package() {
for _config in "${_configurations[@]}"; do
pushd build-${_arch}-${_config##*=}
- make INSTALL_ROOT="$pkgdir" install
+ make -j$(nproc) INSTALL_ROOT="$pkgdir" install
# use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then
@@ -78,6 +86,9 @@ package() {
done
fi
+ # remove '.static.prl' files
+ find "${pkgdir}/usr/${_arch}" -name '.static.prl' -delete
+
find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name '*.dll' -delete
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete || \
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..6ccd2981b85a
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,14 @@
+% layout 'mingw-w64-qt5-module';
+\
+% content_for additional_contributors => begin
+# Contributor: ant32 <antreimer@gmail.com>
+# Contributor: Filip Brcic <brcha@gna.org>
+% end
+\
+pkgver=5.15.13
+pkgrel=1
+arch=('any')
+pkgdesc="Provides access to sensor hardware and motion gesture recognition (mingw-w64)"
+depends=(<%== qt5deps qw(base declarative) %>)
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
diff --git a/qtsensors-sha256.txt b/qtsensors-sha256.txt
new file mode 100644
index 000000000000..fdea0f1bccd3
--- /dev/null
+++ b/qtsensors-sha256.txt
@@ -0,0 +1 @@
+38eb6df8dc8c7346bec8a6e758c2798ff4a3547056c03189c9a6d4581fc9cd05